• No installation possible (cnchi and CLI)


    Hi to everyone :)

    I searched the forum if my issue may already solved but I didn’t found a topic matching my problems:

    I never used Antergos before (always a Debian before) and trying to install Antergos on my brand new Notebook.

    So my hardware setup is very fresh:

    • Intel Core i7-6820HK Skylake CPU
    • NVIDIA GeForce GTX 965M 2048MB GDDR5
    • 256GB m.2 SSD Samsung SM951-NVMe (MZVPV256HDGL) - connected via PCI-Express
    • 1000GB SATA-III 5400U/Min WD Blue Slim (WD10SPCX)
    • 500GB / 8GB SATA-III SSH 5400U/Min Seagate Laptop Thin SSHD (ST500LM000)
    • Intel Dual Band Wireless-AC 8260

    .
    First try: Using cnchi

    • Downloaded “antergos-2016.02.21-x86_64.iso” and verfified it’s checksum

    • Created an USB image of “antergos-2016.02.21-x86_64.iso” with Suse Image Writer (and again because of the following probs to ensure that the image itself is fine)

    • Booted into antergos live session

    • Started cnchi from CLI (to get an idea what’s happening - it makes absolutely NO difference if using the cnchi directly shown at boot)

    • set language

    • System information screen is blank (see screenshot in uploaded tgz) so skipped to next step

    • Choosing ANY desktop (it doesn’t matter which one) will let cnchni hang completely and forever (see cnchni-terminal.log in tgz and the cnchi.log of course)
      –> The reason for this may because of the command “lspci -n” executed by cnchi. This process is totally unresponsive and cannot be killed even not with “kill -9”. Only a reboot can solve that.
      The same happens when executing the command “lspci -n” manually: Not able to kill and a reboot is required
      Well we could say: this seems to be a problem of my hardware setup maybe it is too new or something so I decided to go another way:

    • if choosing “Base” instead(!) of a desktop flavor I can continue to the next step for choosing AUR etc

    • I then choose the manual setup which let me go to the next screen

    • But the next screen is blank and should normally let me choose my manual partitions I could skip to the next screen but that would mean to skip where antergos should be installed…
      For this please see "cnchni_BASE.log"
      The reason why that may happens seems to be more clear in this case:
      cnchi tries to get information from my LVM partitions with the wrong command! It states “command … btrfs … non-zero exit status…” Well that indeed cannot work as those partitions are all XFS - not btrfs as you can see in the cnchni_BASE.log. UPDATE: For this I added this bug report: https://github.com/Antergos/Cnchi/issues/550

    Content of logs.tgz:

    • cnchi.log
    • cnchi-terminal.log --> the output from the terminal where I executed “sudo cnchi”)
    • highcpuusage.txt --> the output of “ps” showing a continues 99% CPU usage of lspci
    • pacman*
    • screenshot_emptyscreen.png --> this is the screen of the “system check”
    • screenshot_hang.png --> this is the screen after selecting GNOME as my desktop flavor and then cnchi hangs (because of lspci?!)

    .
    Second try: Using /arch/setup

    Ok so I thought there have to be a CLI installer somewhere, right? I also tested manjaro and there I saw the /arch/setup thing which is also available in antergos (I haven’t found any info on this btw)

    • I started /arch/setup and was able to walk to all the things very well! I was able to select my manual created partitions and so on fine!
    • When it comes to installation and I choose a desktop (e.g. GNOME) the setup hang forever
    • If I choose “base” it is the same I cannot continue (see arch-setup.log) and have to use CTRL+C to abort
      The interesting part is that when using /arch/setup the reason of a high cpu load is here: “hwinfo --gfxcard”

    so well I’m a little bit lost now…
    It would be ok for me if using cnchi would work for me with BASE instead of a desktop flavor but this is not possible because of the filesystem bug (btrfs when it is xfs).

    Content of logs2.tgz:

    • cnchi.log_BASE --> the chnchi.log when selecting NO desktop so “Base” only
    • cnchi_BASE.log --> the output from the terminal where I executed “sudo cnchi” and choosing the “base” install
    • arch-setup.out --> the terminal output when using /arch/setup
    • arch-setup.highcpu --> the output of “ps” showing a continues 99% CPU usage of hwinfo
    • packages.xml --> as /arch/setup downloads this I thought it couldn’t harm to add it here

    .
    Where I end up with:

    As none of the above installation methods worked for me I installed antergos this way instead:

    • doing all mounts manually (including binds etc)
    • doing a rsync of the running antergos to my new root partition
    • doing all the stuff like mkinitcpio, grub-install manually within the chroot
    • removing livecd stuff like the systemd scripts and virtualbox guest additions etc.
      I saw at the end that using pacstrap may have been the better way but well … next time ;)

    That way I can boot my antergos system now but I hope that the above errors and problems described helping to make cnchi and/or the /arch/setup working for others…

    Greetings
    archjog

    [1_1456507643549_logs2.tgz](Uploading 100%) [0_1456507643548_logs.tgz](Uploading 100%)

    EDIT:
    I’m not able to upload any files here. I always get a message from nginx “Request Entity Too Large”! The filesize is 1,6 MB?!
    Please see: http://s000.tinyupload.com/download.php?file_id=02020685443536475473&t=0202068544353647547375141 do download all the logs instead…

  • Well at least someone who is a new comer to this distro was able to figure out an installation method that proved successful.
    Thanks so much for your input.
    Hopefully others will be aware of your methodology used.

    Other than utilize your method and with respect to CLI, when I first installed Cinnarch a few years ago (Now called Antergos), I used CLI as I also had problems with GUI install (it would hang).
    CLI install did it for me quite successfully and I, personally would recommend that route.
    Regardless…

    As for uploading files to your own post, there is something wrong with the uploading mechanism. Not sure what. I have never once been able to upload anything to my own posts and as such have always had to resort to pastebin.
    For that, you cannot do much other than to possibly blame the Wordpress theme? None too sure but that is my guess.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

setup3 installation214 live35 cnchi113 Posts 2Views 2781
Log in to reply