• Like 0

    Can't suspend/sleep, systemd-udevd refusing to freeze


    Lately (for the last week or so) I’ve been unable to put my laptop to sleep. Sometimes I’ll be able to suspend after the first suspend fails, sometimes I won’t be able to suspend at all regardless of how many times I try. Relevant dmesg (it repeats twice per occurance):

    [40721.592240] .........................
    [40745.697492] wls1: deauthenticating from 00:a4:cf:95:42:1a by local choice (Reason: 3=DEAUTH_LEAVING)
    [40745.847801] PM: Syncing filesystems ... done.
    [40745.865979] PM: Preparing system for sleep (mem)
    [40746.676747] .
    [40747.476792] Freezing user space processes ... 
    [40747.680178] ....................
    
    [40767.481369] Freezing of tasks failed after 20.003 seconds (1 tasks refusing to freeze, wq_busy=0):
    [40767.481648] systemd-udevd   D ffff88007110f9c8     0 12351  12344 0x00000004
    [40767.481658]  ffff88007110f9c8 ffff8802d5b125c0 ffff88046c419b80 ffff8802e3ccee00
    [40767.481665]  ffff880071110000 0000000100b8f3d4 ffff88007110fa00 ffff88047f04dc00
    [40767.481671]  0000000000000003 ffff88007110f9e0 ffffffff8158e03c ffff88047f04dc00
    [40767.481677] Call Trace:
    [40767.481694]  [<ffffffff8158e03c>] schedule+0x3c/0x90
    [40767.481702]  [<ffffffff81590a25>] schedule_timeout+0x125/0x240
    [40767.481710]  [<ffffffff810dfcd0>] ? init_timer_key+0xb0/0xb0
    [40767.481716]  [<ffffffff810e0d9d>] msleep+0x2d/0x40
    [40767.481726]  [<ffffffffa0064e17>] sd_revalidate_disk+0xa87/0x1bf0 [sd_mod]
    [40767.481734]  [<ffffffff811e21f6>] ? get_super+0x26/0x30
    [40767.481744]  [<ffffffff8121911f>] check_disk_change+0x5f/0x70
    [40767.481750]  [<ffffffffa00642bf>] sd_open+0x8f/0x160 [sd_mod]
    [40767.481757]  [<ffffffff8121876f>] __blkdev_get+0xef/0x430
    [40767.481763]  [<ffffffff81219512>] blkdev_get+0x132/0x360 
    [40767.481770]  [<ffffffff812197eb>] blkdev_open+0x5b/0x70
    [40767.481778]  [<ffffffff811dcbdf>] do_dentry_open+0x1ff/0x300
    [40767.481784]  [<ffffffff81219790>] ? blkdev_get_by_dev+0x50/0x50
    [40767.481791]  [<ffffffff811ddd46>] vfs_open+0x56/0x60
    [40767.481796]  [<ffffffff811ec528>] path_openat+0x4d8/0x10c0
    [40767.481805]  [<ffffffff8109f642>] ? default_wake_function+0x12/0x20
    [40767.481811]  [<ffffffff811ee5e1>] do_filp_open+0x91/0x100
    [40767.481822]  [<ffffffff812cf972>] ? memzero_explicit+0x12/0x20 
    [40767.481828]  [<ffffffff811fb247>] ? __alloc_fd+0xc7/0x190
    [40767.481835]  [<ffffffff811de116>] do_sys_open+0x146/0x230
    [40767.481841]  [<ffffffff811de21e>] SyS_open+0x1e/0x20
    [40767.481846]  [<ffffffff81591b2e>] entry_SYSCALL_64_fastpath+0x12/0x71
    
    [40767.481856] Restarting tasks ... done.
    [40767.502009] video LNXVIDEO:00: Restoring backlight state
    [40767.508036] PM: Syncing filesystems ... done.
    

    Laptop: Asus ROG 751JL (i7-4720HQ CPU @ 2.60GHz, 16 gigs of RAM, GTX 965M)

  • Like 0

    Not too sure if this would help, but can you have a look at the pm-utils section of the Wiki
    https://wiki.archlinux.org/index.php/pm-utils

    Also, from the Arch Wiki,

    Suspend/hibernate doesn't work, or not consistently
    
    There have been many reports about the screen going black without easily viewable errors or the ability to do anything when going into and coming back from suspend and/or hibernate. These problems have been seen on both laptops and desktops. This is not an official solution, but switching to an older, especially the LTS-kernel, will probably fix this. 
    

    Is the above of any help?

    The ARCH WIKI: /https://wiki.archlinux.org/

  • Like 0

    @Modisc I don’t have pm-utils installed (I use tlp instead). Though since the article appears to say that’s a kernel issue, downgrading might be worth a try. I’ll report back in a day or two.

  • Like 0

    sure. definitly report back success or failure. I will try to help as much as I am knowledgably able to.

    The ARCH WIKI: /https://wiki.archlinux.org/

  • Like 0

    So, a day or two turned out to be a week or two.

    Results:

    Attempt 1: I found there was a newer kernel than the one I had, so I upgraded. This was a bad move because it turned out that nVidia driver (or lightdm) didn’t like the new kernel, meaning lightdm wouldn’t start. (I didn’t downgrade because I’d have to downgrade a lot of things at once.) Things worked okay for a few days, then I was unable to sleep again.

    Attempt 2: Downgrade. I spent few hours hunting for which version is compatible with what (and unscrewing whatever downgrading nVidia’s driver messed up). That fixed it (for a few days at least, sunday till today). However, now I’m running on a bad version of nVidia driver (some games will refuse to launch), which means I’m probably going to update the first second pamac notifies me of a new kernel.

  • Like 0

    hi again
    Ok, I see what you are now facing. Right now, and only at this moment, all I can think of is to try the LTS version of the kernel. It’s stable.
    Would you attempt that at least to see where it gets you? Get a stable system working first and then let’s concern ourselves with Nvidia.

    The ARCH WIKI: /https://wiki.archlinux.org/

Posts 6Views 793
Log in to reply