• Error - systemd[1]: Failed to start Setup Virtual Console.


    I’m installing Antergos (antergos-2016.02.21-x86_64) on my Asus R751L laptop, though I has some obstacles I managed to boot my live usb and install the OS. However, when I try to boot it up for the first time I get this error message: [I apologize for the bad quality picture]

    I googled for a solution and tried the suggestion to modify “vconsole.conf” in the root partition through the live usb, which just left me with a blinking underline and without any error message at all upon boot.

    What is the reason for this error? How can I solve it? Please ELI5.

  • @antagonicpunksystem said:

    And yet the error is caused by malconfigured /etc/vconsole.conf on
    the installed system.


    I googled for a solution and tried the suggestion to modify “vconsole.conf” in the root partition through the live usb, which just left me with a blinking underline and without any error message at all upon boot.

    I can’t quite understand what are you saying here. vconsole.conf exists and is found in the specific folder, which is /etc, not in generic “root partition”.

    LiveUSB has nothing to do with it. Simply edit the file on already installed system. Why use LiveUSB?

    When /etc/vconsole.conf contains a correct country code for the keyboard to use in VTs (terminals) it is normal that the screen is blank (black) during boot. No error messages are issued. Only two lines are displayed:

    • systemd version number
    • fsck message about checking the root partition

    Finally, does the system boot or not?

    If the system boots, either in graphic or text mode, can you post back here the full output of the command

    sudo cat /etc/vconsole.conf
    

    It looks like

    $ sudo cat /etc/vconsole.conf
    [sudo] password for just: *********
    KEYMAP=uk
    FONT=
    FONT_MAP=
    $ 
    

    The main parameter here is the KEYMAP= value.

    Also, what keyboard layout do you have?

  • @just
    I’m sorry for my poor description of the issue, I’m a Windows user that are looking into making a transition to a Linux based OS, I have none whatsoever previous experience of Linux beyond that I’ve tried out Ubuntu and Linux shortly.

    The thing is that I can’t boot into my installation at all, the only way for me to reach my files is by booting up by my live usb and mounting the already installed partions. I can’t get beyond the error message in the first time setup that I posted a picture of - After the failing of loading the Setup Virtual Console the screen just shows a blinking underline without proceeding any futher, after which I have to do a hard reset to get out of.

    I found the vconsole.conf in /etc/ and opened it through the terminal as su and deleted the single line that was there “KEYMAP=se” and then saved the file, this I did due to following some instructions blindly that I found googling for a solution to the error.

    My keyboard layout is “se” for a Swedish layout.
    I’ll try to the sudo command through my live boot and see if I can get return with any output.

    Thank you kindly for the help, it’s much appreciated!

  • @antagonicpunksystem said:

    @just
    I’m sorry for my poor description of the issue, I’m a Windows user that are looking into making a transition to a Linux based OS, I have none whatsoever previous experience of Linux beyond that I’ve tried out Ubuntu and Linux shortly.

    That’s OK. But Arch is probably the least user-friendly system to transit from Windowz. It is even considered as hard to use by some Linux users.

    The thing is that I can’t boot into my installation at all, the only way for me to reach my files is by booting up by my live usb and mounting the already installed partions. I can’t get beyond the error message in the first time setup that I posted a picture of - After the failing of loading the Setup Virtual Console the screen just shows a blinking underline without proceeding any futher, after which I have to do a hard reset to get out of.

    OK, forget about Setup Virtual Console message for a while. It’s just an old message issued earlier. It never blocks the system. At worst, you’ll get a wrong keybord in terminals only. The GUI uses the keyboard specified in another place.

    The error that blocks the system is somewhere else. I can’t figure it out from your photo. Everything runs with [OK] exit code.

    Virtual Console may be set later, once the system is installed. Again, it never blocks the boot process.

    I found the vconsole.conf in /etc/ and opened it through the terminal as su and deleted the single line that was there “KEYMAP=se” and then saved the file, this I did due to following some instructions blindly that I found googling for a solution to the error.

    Did you edit the /etc/console.conf in the live session? If yes, it has no sense.

    It could be edited in the installed syste. The point where you don’t arrive.

    Never delete the KEYMAP= parameter from the file. Others may be absent, but this one should be present.

    My keyboard layout is “se” for a Swedish layout.

    That’s the excellent value for Swedish.

    To summarize. Your KEYMAP=se is good. Anyway, wrong country code here never blocks the boot. The true error is somewhere beyond that point. I can’t figure it out from attached image.

    Good luck.

  • @just
    I tried to reinstall the OS again (with ‘us’ as keyboard layout) and ended up in the same place as last time. This time however I figured out that I can access the terminal even though it’s just a black screen with a blinking prompt by pressing ctrl+alt+f2.

    Here is the output of sudo cat /etc/vconsole-conf and of systemctl status systemd-console-setup.service: Link to picture

    I just googled the outcome of the “systemclt” and saw that some people with Nvidia GPU have had similar problems, I have an Asus laptop with Intel graphics and Nvidia. Could this be a part of the issue?

  • @antagonicpunksystem said:

    …I have an Asus laptop with Intel graphics and Nvidia. Could this be a part of the issue?

    It’s not just a part, it’s the root of the problem. I was suspecting something similar. Hybrid video cards on Asus hardware is a nightmare. Especially on live boots. Skipping details about that, try to boot in two different modes.

    First, add the nomodeset parameter (just the word) to the boot line. See if it boots.

    If not, try the second trick. Add the vga=789 parameter to the boot line.

    I have no other ideas, for the moment.

Posts 6Views 773
Log in to reply