• Help with Time in a Dual Boot


    Hey guys, I’d like to know if I follow the instructions on this website (http://lifehacker.com/5742148/fix-windows-clock-issues-when-dual-booting-with-os-x) and set my Windows time to UTC, will Windows automatically change the time when its DST (Daylight Savings Time?)

    Thanks!

  • That’s good question. I believe Yes, because Windows is watching for changes like this on it’s own.

    I also use Dual Boot with Windows, but I’ve choose another, not standard way.
    On Linux side I’ve choose to use UTC with online synchronization. On Windows side I didn’t change anything, except some small service, which synchronize time online 30s after every boot.
    I don’t have any problem in Antegros, time is always up-to-date. In Windows I have incorect time for first ~30s.
    Work’s for me.

    By the way, in this article you can read, that if you set Windows to use UTC:

    Should Windows ask to update the clock due to DST changes, let it. It will leave the clock in UTC as expected, only correcting the displayed time.

    I hope that help :)

  • Can someone please confirm this?

  • Install ntpd either from pacman or the Add remove software.
    I.E. in terminal pacman -U ntpd or search for and install from the Add Remove GUI.

    Then in Autostart, (Session and Startup) add a new entry and in the command line put

    ntpd -gg

    It will then go to the internet and set your clock.

    Antergos does not seem to get the timezone UTC offset.
    I trust internet time, and this seems to take care of it easily.
    You can also just run this in terminal, but I just set it to that autostart as it is normally online on my desktop.

    If your in a WiFi world you can create a desktop launcher to do the same, or put a sleep 30 ntpd -gg
    instead to allow time for WiFi to make the connection.

    Now if your running Windows 7 or later, it has already got automatic internet time setting, but I find you have to change the reference to nist.gov as the default one always seems to fail.

    I was going nuts to get Antergos to display the correct time.
    I am hoping a time setting gadget will get added to the system settings panel someday. Until then this is a workaround.

  • man timedatectl

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 6Views 1040
Log in to reply