• Libreoffice Writer has awful gradient in toolbar backgrounds.


    See screenshot
    alt text

    For the life of me, I can’t get Libreoffice Write to use the Breeze/Breeze Dark themes.

    Has anyone else run across this issue in KDE Plasma? Is there a fix?


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • After a considerable amount of research, I was finally able to resolve this issue. Here was the process to fix:

    You need to create, add, or uncomment this line in your /etc/profile.d/libreoffice-fresh.sh file:

    export SAL_USE_VCLPLUGIN=gtk

    You can do so by opening a Konsole and typing the following: sudo kate /etc/profile.d/libreoffice-fresh.sh

    The alternative options in libreoffice-fresh.sh are:

    export SAL_USE_VCLPLUGIN=gen

    export SAL_USE_VCLPLUGIN=kde4

    export SAL_USE_VCLPLUGIN=gtk3 # currently broken and not available

    Simply uncomment (remove the #) for the one you want to choose. THEN LOG OUT AND LOG BACK IN (which I wasn’t doing, initially, so it didn’t look like this fix was working. Once I logged out and logged in, the problem was fixed)!


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • This was bugging the crap out of me for a few days now, your solution fixed the problem nicely, Thanks!!

  • Mine does this with certain themes! Thank you!

  • Muchas gracias, no sabía como arreglarlo.:+1:

  • @jesse.dubord Thank you very much! Your tip solved this problem here.

  • You bet, all. Happy to help! :)


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

Posts 7Views 3105
Log in to reply