• \[Solved\]Control how the power button behaves


    I’m used to see a pop-up window when I press the power button in all distros I’ve used. But somehow this is not happening in my fresh install of Antergos with Cinnamon. It hasn’t even passed a week since I installed Antergos and I’ve already shutdown my machine 2 times accidentaly

    My question is:
    How/What would I configure to make the button to behave as I want?

    I tried this:
    chmod -x /sbin/shutdown
    and somehow the pop-up window comes to live, but inmediatly (I barely see the pop-up window) the computer starts the boot process (I think it is, it shows the same messages) and after 20 secs or so it’s not booting nor turning off, forcing me to shutdown by pressing the button a few seconds.

    I’ve also read about acpid but I’m really confused about it.

    So yea, any help would be apreciated
    Cheers

  • I’m used to see a pop-up window when I press the power button in all distros I’ve used. But somehow this is not happening in my fresh install of Antergos with Cinnamon. It hasn’t even passed a week since I installed Antergos and I’ve already shutdown my machine 2 times accidentaly

    My question is:
    How/What would I configure to make the button to behave as I want?

    I tried this:
    chmod -x /sbin/shutdown
    and somehow the pop-up window comes to live, but inmediatly (I barely see the pop-up window) the computer starts the boot process (I think it is, it shows the same messages) and after 20 secs or so it’s not booting nor turning off, forcing me to shutdown by pressing the button a few seconds.

    I’ve also read about acpid but I’m really confused about it.

    So yea, any help would be apreciated
    Cheers

  • You can set the action your system takes upon power button press from the Cinnamon System Settings Panel.

    Menu>Preferences>Cinnamon System Settings>Power Management>Power Button Action>Ask

    Cheers!

  • I forgot to say I also tried that one

    None of the options there work, the system just turns off

    What direction do You think I should take here to solve this? Do you know what’s the file I’m overwriting when I change the settings there?

    Thanks

  • No, there are no conf files for cinnamon/gnome. All settings are stored as keys that are accessible with the dconf gui app. I’m betting that cinnamon is correctly setting the key but something else is overriding control of the button. Try editing /etc/systemd/logind.conf and change the buttons to “ignore” and reboot your system. Then use system settings to set them the way you want and give it another try.

    Best Regards,

  • yay

    I changed this line:
    #HandlePowerKey=poweroff
    to this (not sure if this was what you mean):
    HandlePowerKey=ignore
    just made a reboot and it’s working know

    sorry if at the end this was the wrong subforum to post this

    Thanks

  • Yep, you got it! I’m glad to have helped! No worries about the post category…You will soon notice that we do things a little differently here than you may have experienced elsewhere

    Cheers!

Posts 7Views 1051
Log in to reply