• Dual Boot not seeing Windows10


    So I got a new laptop with Windows 10 on it and it has a 480 SSD in it. I decided since I use very little space (currently on 128 SSD) that a dual boot would be fine.

    Problem is, after shrinking the partition for windows and installing Antergos in the empty partition it no longer sees Windows. Antergos grub doesn’t pick up that Windows 10 is there on bootup.

    Everything else as far as Antergos is working . Is there an easy fix for grub not seeing Windows? Using the most current iso and UEFI also.

    PS: (No sense in deleting an OS that you have to pay for…Right? Right?? :P )

  • don’t know if I can be of much assistance, @linuxhelmet but what does msinfo32 say inside Windows BIOS mode? UEFI or Legacy? My guess it might say UEFI. But it depends on what you set it too when you installed Antergos?
    Also, what does os-prober return?
    There is one way to help in finding it if the normal routes don’t suffice. It entails editing /etc/grub.d/40_custom file. But editing that file should not really be necessary.

    See if the os-prober helps to figure that out.
    And after it has (hopefully), update your grub configuration.

    Also, have you looked at the Arch Wiki link on dual booting with Wind0zzz?
    https://wiki.archlinux.org/index.php/Dual_boot_with_Windows

    By the way, is this a new set up on a newer laptop or something? I thought you had Antergos already?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I basically followed this tutorial to almost a tee mainly due to not finding anything readily available in the forums.
    Source:
    http://itsfoss.com/dual-boot-antergos-windows-uefi/

    Yes it is set to UEFI, and yes you caught me! :P I already have Antergos but got a new laptop with substantially more power. i7 Lenovo w/ Hybrid Nvidia graphics, 8gb ram, and a 480 SSD.
    I will give os-prober a shot and see what it gives me…

  • It’s always the simple things that get me!
    This fixed it:
    sudo su
    os-prober
    grub-mkconfig -o /boot/grub/grub.cfg
    reboot

    Problem solved! Thanks!

  • Glad to hear of it. :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

dual-boot11 windows 109 Posts 5Views 718
Log in to reply