• No puedo cambiar el DE por defecto


    No se si el titulo lo explica bien, pero a continuación el problema:
    Hace unos días por curiosidad cambie, desde la pantalla de bienvenida, GNOME por GNOME en Wayland, pero nada sucedio, despues de acceder la pantalla volvio a la de bienvenida, asi que cambie a GNOME normal, y todo sin problemas, pero ahora, GNOME en Wayland es la opcion por defecto y es algo molesto tener que cambiar manualmente a GNOME, como puedo quitar wayland de las opciones de DE?

  • @mirielorella jajajajajaj amigo, precisamente eso me pasó y yo puse un tema para encontrar solución, @anarch me dijo que probara con gdm, todo andaba bien.
    Yo decidí reinstalar desde cero, para probar la última ISO y eliminar muchas cosas que me quedaban sobrando. Desde cero funciona bien.

  • Pues reinstalar desde 0es muy drastico para mi, he pasado incontables horas arreglando bugs, problemas con el grub, con el boot, etc como para volver a hacerlo, creo que cambiare a GDM por el momento, quiza quitando y reinstalando ligthdm se solucione el problema, pero gracias!

  • @mirielorella said:

    Pues reinstalar desde 0es muy drastico para mi, he pasado incontables horas arreglando bugs, problemas con el grub, con el boot, etc como para volver a hacerlo, creo que cambiare a GDM por el momento, quiza quitando y reinstalando ligthdm se solucione el problema, pero gracias!

    Pero instalar GDM para poder usar gnome con wayland, forma de solicionar lo de la pantalla de inicio de sessión no conozco, según el mismo usuario, eso después de algún tiempo vuelve a su lugar.

  • Hola,
    a mi me paso algo parecido a lo que comentas, lo solucione editando el archivo /etc/gdm/custom.conf y anulando las lineas que hacen referencia a wayland de la siguiente manera.

    #WaylandEnable=true
    #DefaultSession=gnome-wayland

    reinicias y problema solucionado, volverás a tener gnome en su modo normal, también puedes en vez de anularlas cambiarles el valor de la siguiente manera.

    WaylandEnable=false
    DefaultSession=gnome

    Saludos.

  • @kmi Esto funciona también si no tengo instalado gdm?

  • @alaguna , maybe I have not made myself clear on your own post. What I said was that I have changed from lightDM to GDM NOT because I wasn t satisfied with it. Everything worked perfect, PLUS it was visually far better. I decided to switch to GDM because I now am using Wayland permanently and I wanted to take advantage of its inbuilt power settings. I had read posts about xscreensaver crashing the session & I did not want to take the risk of trying.:smile:
    The issue with gnome wayland not changing to gnome was present on either DEs. What I found out was, in either DEs, that after picking gnome a couple or so times (after turning on my machine in the mornings or after rebooting, that is) I made the system to finally “remember” the setting and not tickind the gnome wayland
    Whai I would do if the above wasn t a fix, is to

    1. Install ``GDM` (if I didn t have it installed)

    sudo pacman -S gdm

    1. Disable lightDM

    sudo systemctl disable lightdm

    1. Enable `GDM

    sudo systemctl enable gdm
    ,and
    Reboot

    Then, if I wanted to go back to lightdm, I would revert the proccedure
    sudo systemctl disable gdm
    sudo systemctl enable lightdm
    reboot
    and see if plain gnome was set as default.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 7Views 900
Log in to reply