• \[SOLVED\]Problems with the MATE's instalation


    Hi there,
    I installed the Antergos’s base system and I want to install the mate desktop.
    But i get an error that the signature is unknown.
    What’s the problem?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Hi there,
    I installed the Antergos’s base system and I want to install the mate desktop.
    But i get an error that the signature is unknown.
    What’s the problem?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Hi,

    have a look at

    [https://wiki.archlinux.org/index.php/MATE][0]">[https://wiki.archlinux.org/index.php/MATE][1]

    There is an explanation how to add the signing keys.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/MATE

  • Instead of the

      
    SigLevel = PackageRequired  
    Server = http://repo.mate-desktop.org/archlinux/$arch
    

    I use

      
    SigLevel = Optional TrustAll  
    Server = http://repo.mate-desktop.org/archlinux/$arch
    

    It’s working now. But I have a lots of missing things.
    I haven’t network indicator, the brightness manager doesnt work, etc.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • did you installed mate-extra?

    pacman -Syy mate mate-extra
    

    For the backlight add the following to /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux acpi_backlight=vendor”

    and do the following command then

    grub-mkconfig -o /boot/grub/grub.cfg
    
  • @“pseudonym”:1l9kg5so said:

    did you installed mate-extra?

    pacman -Syy mate mate-extra
    

    For the backlight add the following to /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux acpi_backlight=vendor”

    and do the following command then

    grub-mkconfig -o /boot/grub/grub.cfg
    

    Thanks,

    The brightness manager is working now.
    Yes, I installed mate and mate-extra, but I have no indicator (for network), and the mate’s panel is not transparent.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Have you got everything figured out? For your network connection applet you need to install “network-manager-applet”.

    Cheers!

  • [[email protected] ~]$ pacman -Q | grep net  
    glib-networking 2.38.2-1  
    inetutils 1.9.1.341-2  
    mate-netspeed 1.6.0-4  
    net-snmp 5.7.2-8  
    net-tools 1.60.20130531git-1  
    netctl 1.4-2  
    nettle 2.7.1-1  
    network-manager-applet 0.9.8.8-1  
    networkmanager 0.9.8.8-1  
    perl-net-dbus 1.0.0-3  
    [[email protected] ~]$   
    
    

    I have already installed but nothing

    [[email protected] ~]$ pkill nm-applet  
    [[email protected] ~]$ sudo nm-applet  
    [sudo] password for i-sty:   
      
    \*\* (nm-applet:3033): WARNING \*\*: Could not initialize NMClient /org/freedesktop/NetworkManager: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.  
      
    (nm-applet:3033): nm-applet-WARNING \*\*: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.ModemManager1: GDBus.Error:org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory.  
      
    (nm-applet:3033): nm-applet-WARNING \*\*: Failed to register as an agent: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.  
      
    \*\* (nm-applet:3033): WARNING \*\*: fetch\_connections\_done: error fetching connections: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory..  
      
    (nm-applet:3033): nm-applet-WARNING \*\*: Failed to register as an agent: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.  
    
    

    Don't forget to mark as [SOLVED], if your problem was solved!

  • sudo pacman -S modemmanager
    sudo systemctl enable NetworkManager
    sudo systemctl enable ModemManager
    Reboot

    Cheers!

  • @“lots.0.logs”:2usoliwq said:

    sudo pacman -S modemmanager
    sudo systemctl enable NetworkManager
    sudo systemctl enable ModemManager
    Reboot

    Cheers![/quote:2usoliwq]
    The modemmanager was installed.
    I followed your instructions.
    I have no error, but if the nm-applet is running I have no internet connections

    [[email protected] ~]$ ping yahoo.com  
    > ping: unknown host yahoo.com  
    > [[email protected] ~]$ ^C  
    > [[email protected] ~]$ nm-applet   
    > h  
    > ^Cnm-applet-Message: PID 0 (we are 998) sent signal 2, shutting down...  
    > [[email protected] ~]$ pkill nm-applet  
    > [[email protected] ~]$ ping yahoo.com  
    > ping: unknown host yahoo.com  
    > [[email protected] ~]$ nm-applet   
    > ^Cnm-applet-Message: PID 0 (we are 1004) sent signal 2, shutting down...  
    > [[email protected] ~]$ sudo dhcpcd  
    > [sudo] password for i-sty:   
    > dhcpcd[1009]: dhcpcd already running on pid 320 (/run/dhcpcd.pid)  
    > [[email protected] ~]$ pkill dhcpcd  
    > pkill: killing pid 320 failed: Operation not permitted  
    > [[email protected] ~]$ sudo pkill dhcpcd  
    > [[email protected] ~]$ sudo dhcpcd  
    > dhcpcd[1019]: version 6.1.0 starting  
    > dhcpcd[1019]: wlp2s0: up\_interface: Operation not possible due to RF-kill  
    > dhcpcd[1019]: enp1s0: soliciting an IPv6 router  
    > dhcpcd[1019]: enp1s0: rebinding lease of 192.168.2.2  
    > dhcpcd[1019]: wlp2s0: waiting for carrier  
    > dhcpcd[1019]: enp1s0: leased 192.168.2.2 for infinity  
    > dhcpcd[1019]: enp1s0: adding host route to 192.168.2.2 via 127.0.0.1  
    > dhcpcd[1019]: enp1s0: adding route to 192.168.2.0/24  
    > dhcpcd[1019]: enp1s0: adding default route via 192.168.2.1  
    > dhcpcd[1133]: enp1s0: MTU set to 1492  
    > dhcpcd[1019]: forked to background, child pid 1169  
    > [[email protected] ~]$ ping yahoo.com  
    > PING yahoo.com (206.190.36.45) 56(84) bytes of data.  
    > 64 bytes from ir1.fp.vip.gq1.yahoo.com (206.190.36.45): icmp\_seq=1 ttl=46 time=213 ms  
    > 64 bytes from ir1.fp.vip.gq1.yahoo.com (206.190.36.45): icmp\_seq=2 ttl=46 time=292 ms  
    > 64 bytes from ir1.fp.vip.gq1.yahoo.com (206.190.36.45): icmp\_seq=3 ttl=46 time=215 ms  
    > ^C  
    > --- yahoo.com ping statistics ---  
    > 3 packets transmitted, 3 received, 0% packet loss, time 2002ms  
    > rtt min/avg/max/mdev = 213.424/240.635/292.960/37.009 ms  
    > [[email protected] ~]$   
    > 
    

    Don't forget to mark as [SOLVED], if your problem was solved!

  • The dhpcd should not be used at the same time as network manager. You need to disable it with “sudo systemctl disable dhpcd”. Is your network applet appearing in the panel? I had no trouble at all with network connection when I tried MATE a couple months ago. Its possible you are missing a required package. If disabling the dhpcd does not help then post the output from your journal so I can take a look…

    Best Regards,

  • Okay, I try to disable dhcpcd service.

    Here is a screenshot:

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“lots.0.logs”:9fp7qnwp said:

    The dhpcd should not be used at the same time as network manager. You need to disable it with “sudo systemctl disable dhpcd”. Is your network applet appearing in the panel? I had no trouble at all with network connection when I tried MATE a couple months ago. Its possible you are missing a required package. If disabling the dhpcd does not help then post the output from your journal so I can take a look…

    Best Regards,[/quote:9fp7qnwp]

    Thank you very much [b:9fp7qnwp]lots[/b:9fp7qnwp]!
    That was the problem.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • You are welcome!

Posts 14Views 2568
Log in to reply