• lightdm webkit2 greeter conflict


    Hi
    I keep getting a warning about local lightdm webkit2 greeter being newer than Antergos lightdm webkit2 greeter. The warning goes as follows
    Warning: local lightdm-webki2- greeter (2.0.0-2) newer than Antergos lightdm-webkit2-greeter (2.0.0-1 )
    Any ideas of how come and what shall I do, please?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Even though I’m in fear to respond you now, I’ll try to do it nevertheless :smile: .

    Seems like you have installed lightdm-webkit2-greeter from AUR earlier, and don’t remember about it anymore. Look here:

    $ yaourt lightdm-webkit2
    1 antergos/lightdm-webkit2-greeter 2.0.0-1 (system) [installed]
        A webkit2 greeter for LightDM
    2 aur/lightdm-webkit2-greeter 2.0.0-2 [installed: 2.0.0-1] (36)
        A webkit2 greeter for LightDM
    ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
    ==> -------------------------------------------------------
    ==> no, thanks
    $
    

    lightdm-webkit2-greeter is at 2.0.0-2 in AUR and at 2.0.0-1 in [antergos] repo.

    Remaining in the same session, without logout-login in beetwen, I’d try to uninstall AUR’s lightdm-webkit2-greeter with

    sudo systemctl stop lightdm -- stops the service
    sudo systemctl disable lightdm -- deletes the the softlink to it
    yaourt -R lightdm-webkit2-greeter
    

    and install the standard lightdm-webkit2-greeter immediately after that:

    sudo pacman -S lightdm-webkit2-greeter
    sudo systemctl enable lightdm -- creates the softlink to service
    sudo systemctl start lightdm -- starts it immediately, without reboot
    

    This should remove 2.0.0-2 and install 2.0.0-1.

    Before confirming the uninstall double-check that yaourt effectively is about to remove 2.0.0-2 version.

  • No worries about responding, as I already said.:smile:
    I need to find out how I got the aur package. I am prety sure I did NOT instal it myself. I wouldn t have any reason to “play” with the greeter, as Antergos takes care of it. Besides, I ve been using GDM since November, when I finally switched to Wayland and the warnings started less than a week ago.
    Am I hacked or sth?:punch:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Let’s start with discovering where your lightdm-webkit2-greeter comes from.

    Please, run the command

    pacman -Sii lightdm-webkit2-greeter
    

    If the package comes from standard repos, the command will return an extended information about it. Otherwise, pacman will return the error, saying that the package is not found.

    To cross-check that, run another command

    yaourt -Sii lightdm-webkit2-greeter
    

    This command will never fail. It will return the output like this

    $ yaourt -Sii conky-lua
    Repository     : aur
    Name           : conky-lua
    Version        : 1.9.0-2
    URL            : http://conky.sourceforge.net/
    AUR URL        : https://aur.archlinux.org/packages/conky-lua
    Licenses       : BSD GPL
    Votes          : 16
    Out Of Date    : Yes
    Groups         : None
    Provides       : conky=1.9.0
    Depends On     : alsa-lib libxml2 curl wireless_tools libxft glib2 libxdamage imlib2 lua51 cairo
    Optional Deps  : None
    Conflicts With : conky
    Replaces       : torsmo
    Maintainer     : moonarch
    Architecture   : i686 x86_64
    Last update    : Sat 20 Feb 2016 22:35:48 MSK
    Description    : Lightweight system monitor for X, with Lua support enabled
    
    $
    

    The first line says what repo the package was installed from. I’m using conky-lua because it’s the only package I’ve built from AUR. Use lightdm-webkit2-greeter instead.

  • Both your commands give me Antergos repo and version. The 2.0.0-2 version I am also having, was created on 3rd February 2016. But how? :rage: I remember once having the same issue with Chromium. Again, I had never touched it, other than its Antergos updatings. I let it warning me til after some time, it simply went away…
    Anyway, I ll let it this way for some time and if it persists, I ll follow your “recipe”.
    THANKS!

    Αποθετήριο                   : antergos
    Όνομα                        : lightdm-webkit2-greeter
    Έκδοση                       : 2.0.0-1
    Περιγραφή                    : A webkit2 greeter for LightDM
    Αρχιτεκτονική                : x86_64
    URL                          : https://github.com/antergos/lightdm-webkit2-greeter
    Άδειες                       : GPL3
    Ομάδες                       : system
    Παρέχει                      : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos=2.3.2
    Εξαρτάται από                : lightdm  webkit2gtk>=2.10.2  webkit2gtk<2.12
                                  gtk3>=3.18  gtk3<3.20
    Προαιρετικές εξαρτήσεις      : Ουδέν
    Απαιτείται από               : lightdm-webkit-theme-antergos
    Προαιρετική εξάρτηση σε      : Ουδέν
    Διένεξη με                   : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos
    Αντικαθιστά                  : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos<2.2.4
    Λήψη                         : 551,74 KiB
    Μέγεθος εγκατάστασης         : 1692,00 KiB
    Υπεύθυνος πακέτου            : Antergos Build Server <[email protected]>
    Ημερομηνία δημιουργίας       : Δευ 11 Ιαν 2016 09:30:13 πμ EET
    Άθροισμα MD5                 : 3e462f3f82b5b61ffd02f2706685750c
    Άθροισμα SHA-256             : 214736e6a67268f7233a4a607739d8fee46658b34e214bc05aa709bb91163f4c
    Υπογραφές                    : CDBD406AA1AA7A1D```
    
    ```yaourt -Sii lightdm-webkit2-greeter
    Αποθετήριο                   : antergos
    Όνομα                        : lightdm-webkit2-greeter
    Έκδοση                       : 2.0.0-1
    Περιγραφή                    : A webkit2 greeter for LightDM
    Αρχιτεκτονική                : x86_64
    URL                          : https://github.com/antergos/lightdm-webkit2-greeter
    Άδειες                       : GPL3
    Ομάδες                       : system
    Παρέχει                      : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos=2.3.2
    Εξαρτάται από                : lightdm  webkit2gtk>=2.10.2  webkit2gtk<2.12
                                  gtk3>=3.18  gtk3<3.20
    Προαιρετικές εξαρτήσεις      : Ουδέν
    Απαιτείται από               : lightdm-webkit-theme-antergos
    Προαιρετική εξάρτηση σε      : Ουδέν
    Διένεξη με                   : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos
    Αντικαθιστά                  : lightdm-webkit-greeter
                                  lightdm-webkit-theme-antergos<2.2.4
    Λήψη                         : 551,74 KiB
    Μέγεθος εγκατάστασης         : 1692,00 KiB
    Υπεύθυνος πακέτου            : Antergos Build Server <[email protected]>
    Ημερομηνία δημιουργίας       : Δευ 11 Ιαν 2016 09:30:13 πμ EET
    Άθροισμα MD5                 : 3e462f3f82b5b61ffd02f2706685750c
    Άθροισμα SHA-256             : 214736e6a67268f7233a4a607739d8fee46658b34e214bc05aa709bb91163f4c
    Υπογραφές                    : CDBD406AA1AA7A1D```

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 5Views 1109
Log in to reply