• Get back antergos login screen (lightdm, i guess)


    I was experimenting with my setup when I, let’s say accidentally, remove lightdm and installed & enabled gdm with the following command:
    sudo pacman -Rcc lightdm
    sudo pacman -S gdm
    sudo systemctl -f enable gdm

    Now I’ve tried reintalling lightdm hoping to get default antergos login screen running the same commands, obviously inverted, but it doesn’t work, but after reboot i cant login to my computer because neither gdm or ligthdm are enabled, help please

  • @mirielorella It wasn’t enough just to uninstall lightdm. It was | is also necessary to stop and disable its service (daemon).

    As far as I understand, you have both lightdm and gdm services enabled right now. To stop lightdm only:

    1. Boot into bash console with
      systemd.unit=multi-user.target
      
    2. Login and issue the commands
      sudo systemctl stop lightdm  -- it could fail; don't bother
      sudo systemctl disable lightdm
      
    3. Reboot
      sudo shutdown -r now
      

    This should leave only gdm enabled and running. Hopefully, the system will permit to login with GDM after reboot.

    Good luck.

  • @mirielorella Even if you do not get a DM screen you probably get the console screen asking for your login name and after that your password. (you won’t see your password printed)

    The you should get a line with your name and $.
    Here you have to give a command to start your DE. try:
    $ startx **
    if you use Xfce ** $ startxfce4

    If you are sure you have also installed the lightdm-theme try:

    S sudo systemctl enable lightdm --force

    If you also removed the theme you should try to reinstall it. Personally I prefer to use yaourt.

    $ yaourt lightdm or $ yaourt lightdm-webkit-theme-antergos or lightdm-webkit2-greeter

    Using pacman: $ sudo pacman -S lightdm-webkit2-greeter

    The advantage of using yaourt is that you can see the different choices you have. There are several themes you could use I guess.

    Choose the number corresponding with the theme you want to use.

  • @just @axioma thank you! I was able to login and enable GDM, and once I was able to enter my DE I installed and enabled LigthDM with antergos theme, wich is exactly what I wanted!
    Cheers

  • @mirielorella Thank you for marking the topis as [Solved] 👏 .

  • @just thank you for being awesome, you have helped me like one million times already, cheers!!

Posts 6Views 1580
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.