• \[SOLVED\] Problem with some file associations


    Hello
    I cant set mpg and mp4 files to open with VLC player.
    Right click, “properties”, “open with” does not work.
    Set VLC as default player on Gnome settings is not working too, Gnome always reverts the default player to smplayer.

  • Hello
    I cant set mpg and mp4 files to open with VLC player.
    Right click, “properties”, “open with” does not work.
    Set VLC as default player on Gnome settings is not working too, Gnome always reverts the default player to smplayer.

  • Do you have wine installed? Do you use it to run any windows programs on a regular basis? The reason I ask is because I have noticed that everytime I run a wine program, it resets all of my file associations. Every Time like clockwork. If I used winde often then it would be extremely annoying, but I dont use it much.

  • I don’t use wine.

  • mpg and mp4 formats open with VLC now.
    But all other formats open with smplayer and I can’t change the settings.
    Gnome setting for default video player is still not working correctly.

  • Are you using Nautilus as your file manager? System defaults are always ignored in favor of user-specific defaults. Check this file and see if its where your problem is. If you aren’t sure, just delete it and then use Nautilus to set your defaults again. That should fix it for you!

    [code:2ve1a0x1]~/.local/share/applications/mimeapps.list[/code:2ve1a0x1]

    Cheers!

  • @“lots.0.logs”:1zy8l66f said:

    just delete it and then use Nautilus to set your defaults again. That should fix it for you!
    [code:1zy8l66f]~/.local/share/applications/mimeapps.list[/code:1zy8l66f]
    [/quote:1zy8l66f]
    Solved!
    Thanks.

  • You are most welcome! I don’t know why that solution did not occur to me from the beginning. I was in the middle of typing another suggestion when it finally dawned on me “why not just erase the list stupid!” hahahaha

Posts 9Views 1052
Log in to reply