• Wayland 1.10 gnome session problem


    Hi guys, how are you?

    I have a problem now, when i try to login in gnome with wayland i can’t init session, ever send me to login screen, ever.

    I think that the problem is the new Waylando version, today i updated Antergos:

    
    [2016-02-18 12:20] [PACMAN] Running 'pacman -Syu'
    [2016-02-18 12:20] [PACMAN] synchronizing package lists
    [2016-02-18 12:20] [PACMAN] starting full system upgrade
    [2016-02-18 12:20] [ALPM] transaction started
    [2016-02-18 12:20] [ALPM] upgraded libsystemd (228-4 -> 229-2)
    [2016-02-18 12:20] [ALPM] upgraded avahi (0.6.32rc-4 -> 0.6.32-1)
    [2016-02-18 12:20] [ALPM] upgraded bzr (2.6.0-1 -> 2.7.0-1)
    [2016-02-18 12:20] [ALPM] installed libvoikko (4.0.2-1)
    [2016-02-18 12:20] [ALPM] upgraded enchant (1.6.0-6 -> 1.6.0-7)
    [2016-02-18 12:20] [ALPM] upgraded libwbclient (4.3.4-1 -> 4.3.4-2)
    [2016-02-18 12:20] [ALPM] upgraded wayland (1.9.0-1 -> 1.10.0-1)
    [2016-02-18 12:20] [ALPM] upgraded systemd (228-4 -> 229-2)
    [2016-02-18 12:20] [ALPM] upgraded pamac (3.0.0-4 -> 3.0.1-1)
    [2016-02-18 12:20] [ALPM-SCRIPTLET] gtk-update-icon-cache: Cache file created successfully.
    [2016-02-18 12:20] [ALPM] upgraded smbclient (4.3.4-1 -> 4.3.4-2)
    [2016-02-18 12:20] [ALPM] upgraded systemd-sysvcompat (228-4 -> 229-2)
    [2016-02-18 12:20] [ALPM] upgraded virtualgl (2.4.1-1 -> 2.5-1)
    [2016-02-18 12:20] [ALPM] transaction completed
    

    Until now i can login with gnone and budgie, but not with wayland.

    The problem is that now gnome wayland appears by default in init option, i have to change manually to gnome.

    Thank you very much, i wait that for the next installation ISO this problem will fixed.

    Thanks.

  • Hi,

    Don’t know about your wayland problem. About your session, you can try to create a file in your home directory called .dmrc (note the starting dot). If your user is alaguna, the full file path should be: /home/alaguna/.dmrc with this contents:

    [Desktop]
    Session=gnome
    

    If this still does not work, then you’ll have to edit lightdm configuration:
    sudo nano /etc/lightdm/lightdm.conf and check for user-session parameter, it should read:
    user-session=gnome-shell

    Cheers!

  • @karasu said:

    If this still does not work, then you’ll have to edit lightdm configuration

    Hmmm, just a thought! Are you using LightDM @alaguna? I have switched to GDM (mainly for power saving reasons). So, if you are on LightDM, why not give GDM a try to see if youcan retrieve your WAYLAND session?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @karasu well man, doesn’t works, wayland doesn’t works :’( I have Gnome with Wayland by default in Desktop Chooser in Login Screen yet.

  • OK.

    Can you post here (or better, use pastebin or some similar service) your lightdm configuration? (its /etc/lightdm/lightdm.conf)

  • @karasu I have the default configuration, i think, but, i put here it:
    http://pastebin.com/tghdyCKB

  • user-session=gnome

    I don’t know what’s wrong, you have set gnome as user session, so there must be somewhere else that gnome-wayland is selected by default.

    You could try GDM as @anarch suggested.

  • @karasu I reinstalled Antergos, and CNCHi destroy my MBR, thank’s.

  • I reinstalled Antergos, and CNCHi destroy my MBR, thank’s.

    If you don’t give us a proper description of your problem we can’t help you.

Posts 9Views 2284
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.