• Can't fix screen tearing in KDE Plasma 5.5.4 w/ Nvidia graphics


    I’m not able to remove screen tearing at all. I’ve tried every Opengl 2.0 and opengl 3.1 setting configuration in the Compositor widget, but there’s still tearing when I move Windows or, particularly, run Blender for 3D graphics and animation, or Kdenlive for video editing.

    Does anyone know a solid way to remove screen tearing completely?

    (Using Nvidia’s latest 361 proprietary graphics drivers for an Nvidia 970ti graphics card, if that helps.)


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Have you tried playing around with EGL? It’s in the video composite settings. Using EGL pretty much fixed my screen tearing issues.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @jesse.dubord For me tearing has completely gone when I set Tearing prevention (“vsync”) to Full screen repaints.

  • Thanks, all. I did a little tinkering, including setting to full screen repaints, but to no avail.

    Turns out the Nvidia settings were able to supercede any Kwin compositing effects. I followed the simple steps in this link, and it worked brilliantly: https://wiki.archlinux.org/index.php/NVIDIA#Avoid_tearing_with_GeForce_500.2F600.2F700.2F900_series_cards.

    Hope this can help others who run into this issue with Nvidia cards.


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

Posts 4Views 2310
Log in to reply