• Antergos doesn't boot: No gdm or lightdm


    Hello everybody,

    I guess I did something stupid. I accidentally disabled lightdm without enabling gdm.
    When I start my Antergos, after I entered my password for the system (un-)encryption, I just get a black screen and not the user login screen. I can’t switch with ctrl-alt+f keys to other consoles, nothing happens. The fallback mode does not work either. Can’t access my pc via ssh, it’s unfortunately disabled. So my Pc is 100% useless now :-(

    Anyone any idea how to help?

    Thanks in advance
    flennic

  • @flennic150 Try to boot adding the following kernel parameter to the boot line

    systemd.unit=multi-user.target
    

    It will bring you to non-graphical mode with networking enabled. You’ll be able to do everything you need, in bash.

  • Hi just,

    did as you said, but still no change. I still have the black screen and can’t do a thing (no cursor, no input, just nothing).

    Do you have another idea?

    Edit: I will try to create a live iso, start, decrypt my ssd with the live cd and try to set the gdm symlink manually. Any idea whats the command for setting the symlink is? It’s the output from “systemctl enable gdm”

  • I set the symlink from lightdm (which was set) to gdm, looked for the right permissions, but still no changes. I have no idea left.

  • @flennic150 said:

    Hi just,

    did as you said, but still no change. I still have the black screen and can’t do a thing (no cursor, no input, just nothing).

    So the system doesn’t even arrive to the point where it starts a display manager. It blocks somewhere earlier.

    Do you have another idea?

    No, I don’t, I’m afraid.

    Edit: I will try to create a live iso, start, decrypt my ssd with the live cd and try to set the gdm symlink manually. Any idea whats the command for setting the symlink is? It’s the output from “systemctl enable gdm”

    I don’t use gdm. And can’t give you a ready-to-use command to create a softlink for it. I use lightdm. This is how lightdm service works. Most probably the gdm service works the same way.

    The lightdm service itself - a simple text file - is found in the directory

    /usr/lib/systemd/system/lightdm.service
    

    You’ll probably see something like

    /usr/lib/systemd/system/gdm.service
    

    But systemd doesn’t use these services directly. As you correctly said, “systemctl enable” creates a softlink to this service (and “systemctl disable” simply deletes it).

    The softlink is created in the directory

    /etc/systemd/system
    

    with the fixed name

    display-manager.service
    

    So the full softlink’s path+name is

    /etc/systemd/system/display-manager.service
    

    Repeat, this softlink points to (its target is)

    /usr/lib/systemd/system/lightdm.service
    

    Softlinks are created with ln command. Its syntax is quite simple; run ln --help.

    Briefly.

    You will want to create a softlink with the fixed name

    /etc/systemd/system/display-manager.service
    

    that will point to (with the target)

    /usr/lib/systemd/system/gdm.service
    

    It’ll be a hard adventure… Good luck!

    PS. There are “softlinks” and “hardlinks” in Linux. I don’t know what “symlinks” in Linux are. So I prefer to use “softlink” instead of “symlink”.

  • Well thanks for the explanation, I tested it two times, still it doesn’t work. It’s a little bit odd that the system deleted my link the first time, so the second time I made sure its properly unmounted.

    I’ll have another look in it tomorrow. Worst case: Reinstalling the system.

  • @flennic150 said:

    …Worst case: Reinstalling the system.

    I’m sorry.

    While the system is stable and works well - backup, backup, backup.

  • I always do backups thats no problem. I just don’t like setting up the whole system, but I think thats faster than troubleshooting for another 3 hours. But I will look into that again tomorrow. No frustrated decision.

    Anyways, thanks for all your effort.

lightdm89 screen16 gdm33 black34 boot150 Posts 8Views 1690
Log in to reply