• Like 0

    Can't change format & language


    Hi, I’ve recently installed Antergos and I’m loving it, never used an archlinux distro before, but, for some reason the installer didn’t show the screen for selecting format (for dates, numbers, clock) , so i just clicked next, but now my region is set to australia, and everytime I want to change it when I search for formats I can’t find any, this happens with language also, anyone can help?

  • Like 0

    @mirielorella It is a good practice to read or search the forum before asking a question. Please, do it the next time.

    The problem is being largely discussed in this thread. It has also a workaround, that might help to solve the issue. The workaround works well here.

  • Like 0

    While the Cnchi issue is heavily disscused in the forum, I couldn’t find a solution to my problem (change the format ad language). However, I did some research (and, I should’ve done before) and found that you need to generate a locale.gen with the format and language you need.
    For doing so, read this article in the Archlinux Wiki. Thanks
    Locale: https://wiki.archlinux.org/index.php/locale

  • Like 0

    @mirielorella said:

    …but, for some reason the installer didn’t show the screen for selecting format (for dates, numbers, clock) , so i just clicked next,…

    You was referring to Cnchi (the installer) here, wasn’t you? The suggested thread describes how to avoid this exact inconvenience. Nothing else. It’s not about setting locale in Arch.

    Thank you for suggested ArchWiki article. These are my current locales; depending on my geographical location I use one or another. And some time a mix of them.

    $ locale -a
    C
    en_IE.utf8
    en_US.utf8
    fi_FI.utf8
    it_IT.utf8
    ru_RU.utf8
    POSIX
    $ 
    
  • Like 0

    Maybe I wasn’t clear enough, but I asked how to add more formats and languages to the Settings app in antergos (or another archlinux based distro) , which can be done following the instructions in the page I posted above, this may be useful for newbies that want to change their format region from the English Australia (that is selected by default in cnchi) to the one they need without having to reinstall and/or fix the cnchi issue. Again, sorry, as English is not my native language.

  • Like 0

    @mirielorella I’m fully agree with you. Everyone using Arch, especially those who use non default en_US locale, should read and follow the excellent ArchWiki Locale article.

    Cheers.

Posts 6Views 1088
Log in to reply