• Boot takes too long

    Dear Antergos community and helpers,

    My boot process takes all in all around estimated 3 minutes (didn’t use stop-watch ;) ). My observations are as follows:
    normal boot process in the beginning, no problem with grub, but after maybe 10 or 20 seconds, I see the mouse on a black background. From there, it takes 30 seconds to show the desktop (cinnamon), and then it still needs another 2 minutes to be usable. I installed a little widget in the panel to show cpu, mem, net and disk usage and I can clearly see that for these 2 minutes everything is fine except for heavy disk usage. What the hell is it doing?
    You can find attached some logs, though I was not sure which ones would be helpful. The attached ones include xsession-errors, xorg, lightdm, journal and different systemd-analyze outputs. I replaced some login credencials in the xsession-errors with **** and I was wondering what this tracker-project.org in the same log is about?!
    If more logs are needed, please tell me how to get them.

    Thanks in advance for your help and advice!

  • Hi,

    7s with your /dev/sda2 is not normal (imho). It also takes too long to mount your EFI partition.

    Which is your sda layout? And which filesystems are you using on it?

    If you still haven’t read it, here is a well-written guide:

  • Yes I read it, it’s what gave me the idea to include the systemd-analyze logs, but I still haven’t figured out how to proceed.

    sda      8:0    0 698.7G  0 disk 
    ├─sda1   8:1    0   500M  0 part /boot/efi
    ├─sda2   8:2    0  99.4G  0 part /
    ├─sda3   8:3    0   7.9G  0 part [SWAP]
    ├─sda4   8:4    0 171.4G  0 part 
    ├─sda5   8:5    0 419.5G  0 part /run/media/amo/Daten
    └─sda6   8:6    0     1M  0 part 
    sr0     11:0    1  1024M  0 rom  
  • I have similiar problem on my pc-box. Are you using Btrfs by any chance?
    In my case, sometimes boot is so slow, that LXQT hit some time limit and start multiple times (without loaded configuration).

    EDIT: I’ve just notice, that reboot is significantly faster than cold-boot (after night, for example).
    Just turned on systemd-bootchart, I will tell more soon.

    What might be related - when Linux is booting, I get error messages like this:

    lut 15 13:33:47 lnx kernel: BTRFS error (device sda6): could not find root 8
    lut 15 13:33:47 lnx kernel: BTRFS error (device sda5): could not find root 8
    lut 15 13:33:47 lnx kernel: BTRFS error (device sda5): could not find root 8

  • I don’t know where exactly from, but these error messages look familiar to me, I may have seen them on boot or shutdown, too.
    Yes, I do use BTRFS, it’s my root partition’s filesystem:

  • Ok, after two days I’ve find out, that my problems is not related with systemd and real boot process. Using bootchart I’ve find out something more. According to this, my system start in ~25s, which is good. Sadly, it need another 180-240s to get responsive desktop. It’s look like there is some problem with DE (Lxqt).

    I’ve both of us have similiar problem and both of us are using btrfs, maybe it’s somehow related?

  • maybe it is. Unfortunately, it seems like no Antergos user or moderator has any idea on the issue neither… Are you also using Cinnamon Desktop? If yes, we could try and report the iussue on the Cinnamon support forums.

  • @lots-0-logs uses btrfs (at least in the past), but I don’t think he has experienced this issue.

  • Alright, a friend of mine solved the problem for me. I did not understand a lot of what he did and how he got the idea to do so, but the solution consists in turning off inode_cache as btrfs mount option. Turning it off is recommended here, it says:

    inode_cache (since 3.0)
    Enable free inode number caching. Not recommended to use unless files on your filesystem get assigned inode numbers that are approaching 264. Normally, new files in each subvolume get assigned incrementally (plus one from the last time) and are not reused. The mount option turns on caching of the existing inode numbers and reuse of inode numbers of deleted files.
    This option may slow down your system at first run, or after mounting without the option.

  • @amo said:

    Alright, a friend of mine solved the problem for me…

    If you’re sure in it, could you mark the topic as [Solved]? Thanks.


  • @amo Thank’s for the tip. After removing inode_cache from btrfs entries in /etc/fstab boot is now blazing fast again!
    @karasu This option (inode_cache) is added to fstab during installation. Maybe it would be better to install system without it?

  • @Alphanumerix : I’ll check Cnchi and possibly remove it. Thanks for the warning.

Posts 12Views 4146
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.