I recently decided to install Antergos in my computer (late-2009 27" iMac) with our friend the Radeon 4670 (hint: NO). Weird thing that I noticed long ago with Ubuntu and Fedora, and now with Antergos, is that booting (grub image, not UEFI) the Live works flawlessly, but after installation, only option is to disable KMS (nomodeset or radeon.modeset=0 in boot params), otherwise screen goes off.

So I think: hey, it must be something in X11 or boot line that allows Radeon to work.

For now, here’s the log since booting from Live USB (I booted from syslinux):
http://pastebin.com/jcx5uLGq
Also, the dmesg log:
http://pastebin.com/6f4szBjP

Something curious:

  • From line 595 DRM inits, and Radeon driver is on.
  • Line 975&976 show the backlight controller on, so we can adjust brightness.

Well, what’s going on with the installation, that does not work as the Live ISO?

Maybe is this line (11): Feb 11 16:58:00 ant-15.12 kernel: Command line: initrd=/arch/boot/intel_ucode.img,/arch/boot/archiso.img archisobasedir=arch archisolabel=ANTERGOS earlymodules=loop modules-load=loop rd.modules-load=loop udev.log-priority=crit rd.udev.log-priority=crit quiet splash BOOT_IMAGE=/arch/boot/vmlinuz

There’s some point, maybe I should port some of the live grub orders in the installation in order to get the drivers to work.

I think to put also grub_gfxmode=2560x1440x24 would make it work, what do you think?

I hope we all could get it fixed, I really want to use Arch on my Mac :sweat_smile:

Later today I will investigate further this issue, maybe this will help more people Ok, no time today, nor time this weekend, so by Wednesday I’ll have further investigated this. I’ll report X.org logs and xsession.

EDIT: No luck. Possible options would be to recompile the kernel, and that’s too much time without warranty.
Only thing I’m doing is disabling radeon, enabling i915 graphic and that makes some work. Now the only problem is fullscreen movies, but I don’t care.