• Wrong keyboard


    Hi all,
    yesterday i installed antergos and i choosed italian default keyboard in the setup process, but finished the installation the layout keyboards is US. I tried to change it manually in many ways following guides or forum’s topic but nothing worked.
    I decided to reinstall it, maybe somthing went wrong during the installation, but i still have us keyboard.

    I installed mint, manjaro and windows 8.1 on the same hard disk and i never had problems with the keyboard.

  • @ogreye77 Mi sembra di ricordare, che questa particolarita’ di Cnchi e’ stata gia’ discussa in passato. Cnchi usa la tastiera scelta durante l’installazione, pero’ non la imposta come default nel sistema installato. Imposta la English (US) di default invece.

    Quando il sistema e’ installato, si puo’ aggiungere un’altra tastiera, anche piu’ di una. English (US) la puoi tenere o buttarla via.

    In bocca al lupo.

    IIRC, this problem was already discussed earlier. Cnchi uses the chosen keyboard during installation, but always sets English (US) as the default keyboard in the installed system.

    Once the system is installed, it is possible to add any keyboard you like, even more then only one. It is possible to keep the English (US) keyboard or to remove it.

    Good luck.

  • localectl

    From the output of there you can see what needs changing

  • I tried with “localectl”, here the results:

    localectl status
    System Locale: LANG=it_IT.UTF-8
    VC Keymap: it
    X11 Layout: it

    then i also tried with “setxkbmap -print -verbose 10” , and this is it:

    setxkbmap -print -verbose 10
    Setting verbose level to 10
    locale is C
    Trying to load rules file ./rules/evdev…
    Trying to load rules file /usr/share/X11/xkb/rules/evdev…
    Success.
    Applied rules from evdev:
    rules: evdev
    model: pc105
    layout: us,it
    variant: ,
    Trying to build keymap using the following components:
    keycodes: evdev+aliases(qwerty)
    types: complete
    compat: complete
    symbols: pc+us+it:2+inet(evdev)
    geometry: pc(pc105)
    xkb_keymap {
    xkb_keycodes { include “evdev+aliases(qwerty)” };
    xkb_types { include “complete” };
    xkb_compat { include “complete” };
    xkb_symbols { include “pc+us+it:2+inet(evdev)” };
    xkb_geometry { include “pc(pc105)” };
    };

    I cant interpet these results, i dont know if they are right or wrong, do you see something?

  • Well from the output it says you have two layouts, us and it.

    Thats the wiki keyboard is section 6.1

    And there is another

    I had this same problem a month ago, I just cant remember which page I used to fixed it, but I have these pages saved.
    I have this vague memory that you have to add some lines, because my localectl is longer than yours
    System Locale: LANG=fr_FR.ISO-8859-1
    VC Keymap: fr
    X11 Layout: fr
    X11 Model: pc105
    X11 Options: terminate:ctrl_alt_bksp

    Edit: Also setxkbmap -layout fr would change the ttyl layout but would not stick after a reboot, thats where I started honing in on the issue.

  • Thank you! The command “setxkbmap -layout it” really works :)

    Now i’m reading your links trying to figure it out how to change the keybard language definitively

Posts 6Views 809
Log in to reply