• Antergos doesn't boot from hdd


    Hello all, it’s my first post on this forum.

    I went into an issue. My Antergos installation doesn’t boot from the hdd it’s installed on.

    I wanted to install Antergos as my work/dev os. I did everything as usually. Booted live cd, followed installation process and it all seemed to end up properly. After the post installation reboot, Antergos didn’t boot. I changed the hdd boot priority in the bios and it didn’t help. GRUB doesn’t start. It is like it wasn’t installed. I tried to reinstall/reconfigure it through a chroot guide i found on Arch forum but it didn’t help.

    I already had Antergos installed and running on this pc with no issues. The only thing that changed is that I switched from Windows 8.1 to Windows 10. The installer of Windows 10 asked my to convert my windows HDD to GPT.

    Some details
    I have 2 physical HDD -> 1TB for windows and 120GB for antergos
    In live CD installer I partition like this :
    sdb linux hdd 120gb
    sdb/sdb1 swap 4gb
    sdb/sdb2 / mount point 116gb

    sdc w10 hdd 1tb
    sdc/sdc1 w10 recovery 450mb
    sdc/sdc2 w10 os rest space (900+gb)

    GRUB location hdd : sdb (linux hdd)

    In the BIOS, HDD boot order :

    1. linux hdd
    2. w10 hdd

    I really can’t figure out why grub isn’t launched. Windows boots instead.

  • Hi
    I have kind of same problem but with dual boot MacOS X / Antergos.
    See my post from a day ago. Antergos installation completed with no errors but not possible to boot because empty EFI, GRUB not installed.

    Is it not weird that you don’t have a sda with a system on it?

    I ask this because i think that my Antergos installation got confused because i install
    /boot/efi
    /
    /home
    on sdb and not on sda, because in my computer sda is an old HDD that i use as home for MacOS X. sdb is a new SSD that i use only for systems.

    I suspect this because i have had a year ago the same problem with dual boot installation of Ubuntu. Then the GRUB was installed in the sda EFI partition while the Ubuntu system was installed on sdb. I have got this working because i have copied the EFI Ubuntu folder.
    But i don’t like Ubuntu, so erased it and searching for a better Linux.

    In my Antergos installation no GRUB at all installed on EFI sda or EFI sdb.
    So, i can’t try to copy the GRUB folder.

  • @bartatantergos the sda was used by an other device. it was the live disk pseudo device or a usb device can’t remember.
    i’ll try to reinstall it with all other devices disconnected as soon as i’m back home. maybe it will change something.

  • Ok, let me know.
    I will also try to reinstall but in my situation there wasn’t a GRUB install in sda or sdb.

  • If this is a RESCUE GRUB> when updating win 10 you take your grub …

    First do an ls to know where your grub

    Second all this, for example:

    set boot = (hd0, msdos4)
    set prefix = (hd0, msdos4) / boot / grub
    insmod normal
    normal

    This is all !
    😆

  • I reinstalled Antergos with only the “Linux drive” connected to the PC. I used the default partition scheme proposed by the first option in the installer and now it works. I reconnected the W10 drive and still working. Unfortunately, I didn’t figure out what was wrong.

    Thank you for replies guys.

boot236 install82 grub225 Posts 6Views 3170
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.