• Steam not working


    So i installed steam but it wont open.Also i found on the internet that i must enable multilib
    but there is no multilib in /etc/pacman.conf.Any ideas people

  • I saw your question in the Google+ group of Antergos. I can only answer the one about the multilib repo.
    You mentioned that you ve installed the i 686 version (meaning the 32bit).
    Multilib repo "allows the user to run and build 32-bit applications on 64-bit installations of Arch Linux…"
    https://wiki.archlinux.org/index.php/multilib
    so it is normal not finding it in your system (if I remember well, Cnchi installs the multilib repo on 64bit systems)…
    Sorry for not being able to help with Steam. I don t play…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Thank you my friend.I installed steam viaWine and that is working but i really need an answer for installing the native version.Help me people

  • @anarch
    The i686 version of Steam is in the Community Repo, x86_64 is in Multilib :).
    https://www.archlinux.org/packages/community/i686/steam/

    @kostagiannis2 What does your terminal say when you open it through there? Command is just steam.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn, I was NOT talking about which repo Steam is in, but answering the question why there was not a multilib repo in the system. I found the question in the Google+ group, I answered it here.
    As for Steam, I really don t mind where it is in either bit version. I have never played, I never will…:laughing:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @Wyn said:

    steam
    This is what i get when trying to run it from terminal.

    Running Steam on arch rolling 32-bit
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    libGL error: unable to load driver: radeonsi_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: radeonsi
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

  • Hi,
    In this thread, the person experienced same issue as you do. There is a solution in there. Hope it will also work for you.
    https://bbs.archlinux.org/viewtopic.php?id=193802

  • @patosz @kostagiannis2

    https://wiki.archlinux.org/index.php/steam#Steam_runtime_issues :+1: .

    Also if you’re using Nvidia proprietary drivers, making sure to replace lib32-mesa-libgl with lib32-nvidia-libgl as that can cause the same issue too :).

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Ok l will try and see what happens

steam55 games10 Posts 9Views 3147
Log in to reply