• Error loading shared libraries: libalpm.so.9


    So when I try to update or install a package, I get now get this error:

    [[email protected] ~]$ yaourt -Syua
    package-query: error while loading shared libraries: libalpm.so.9: cannot open shared object file: No such file or directory
    [sudo] password for alternity:
    :: Synchronizing package databases…
    core is up to date
    extra 1769.1 KiB 2.61M/s 00:01 [#####################################################] 100%
    community 3.3 MiB 3.74M/s 00:01 [#####################################################] 100%
    multilib is up to date
    antergos 522.9 KiB 882K/s 00:01 [#####################################################] 100%
    package-query: error while loading shared libraries: libalpm.so.9: cannot open shared object file: No such file or directory

    I tried looking for the answer in this thread:
    https://bbs.archlinux.org/viewtopic.php?id=160878

    The only input that seemed like it may useful was the following commands:

    #mv /etc/pacman.conf /etc/pacman.conf.backup # just in case
    #mv /etc/pacman.conf.pacnew /etc/pacman.conf

    To replace the pacman.conf file with a new version. I saw the 2 files in their /etc/ directory but after using the first command. the pacman.conf.pacnew file seemed to have dissapeared. Someone uploaded the text for a vanilla arch pacman.conf.pacnew file, but I’m not sure if this will conficct with Antergos or not. Can I use that to replaec my current pacman.conf file?

  • There were a few breaking changes (albeit small) that require Pamac’s code to be updated. IAnd as ussually, Pamac’s developers didn t take long to release an update. Run
    sudo pacman -Syu
    and you are done.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • You’re the man. Thank you!

    EDIT: Solved. – Still see no option to mark my threads as solved anymore.

  • Never mind. It was a quick fix. We discussed it here a few days back, but you probably missed the thread.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Hi man, I did that but I still have the problem :cry:

    I guess it might be something with pacman 5.0.0 because it uses the libalpm.so.10.0.0

  • @Edurolp, sorry to hear that. Does this help?
    https://forum.antergos.com/topic/3826/new-pamac-not-starting
    Anyway, if your issue persists, you ll have to open a new topic, as this one is ticked as solved and few will open it to see it.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Finally I went to their GitHub, downloaded last release from https://github.com/manjaro/pamac/releases and compiled it. Now working fine! ^^

Posts 7Views 5575
Log in to reply