• \[SOLVED\] Monitor Resolution Won't Stay Set


    I"m running Antergos on an HP laptop with onboard Intel graphics. The monitor on the laptop is broken so I use a plugged-in Samsung monitor. The resolution is auto-set at 1440x900, which the laptop monitor supports but the Samsung monitor doesn’t.
    I’ve turned off the laptop monitor and set the Samsung to 1280x1024 in the system settings, but it won’t stay set and have to reset it every time I log in. What do I have to edit to keep the settings I want? Thanks for any help.

  • I"m running Antergos on an HP laptop with onboard Intel graphics. The monitor on the laptop is broken so I use a plugged-in Samsung monitor. The resolution is auto-set at 1440x900, which the laptop monitor supports but the Samsung monitor doesn’t.
    I’ve turned off the laptop monitor and set the Samsung to 1280x1024 in the system settings, but it won’t stay set and have to reset it every time I log in. What do I have to edit to keep the settings I want? Thanks for any help.

  • There are two methods to fix this issue. The first is entering your BIOS setup and disabling the internal display. Whether or not your BIOS will actually display on the external monitor is the question. It varies widely. I am able to get mine to use external display but it usually requires a few reboots in a row before it works. So if you aren’t able to do that the other method is to create a bash script that the display manager will run before launching the greeter. I have an example script for multiple displays here: [http://wiki.antergos.com/tiki-index.php?page=GDM The GNOME Display Manager#Login_Screen_On_External_Monitors][0]">[http://wiki.antergos.com/tiki-index.php][1] … l_Monitors but yours would not need to be that detailed. This would suffice:

    \#!/bin/bash  
    xrandr --output HDMI1 --auto --primary --output LVDS1 --off;  
    exit 0;
    

    If you are using the current default display manager (LXDM) then you need to save the file to /etc/lxdm/LoginReady That should do fix it, LXDM will run the script before showing the login.

    Cheers!

    EDIT: I should mention that you should change “HDMI1” and “LVDS1” to match your system. If you aren’t sure run “xrandr” and it will show you the list.

    [0]: <a href=
    [1]: http://wiki.antergos.com/tiki-index.php

  • Unfortunately my bios won’t show up on the attached Samsung monitor. I tried the other solution but no joy. I’ve run a number of distros but Antergos is the first one where I can’t get the monitor resolution to stick. I really like Antergos, but constantly changing the monitor setting is driving me nuts. I don’t know what to do except change distros.

    EDIT: I modified your “displayfix” script for my situation and it takes some steps out of the configuration, making it less of a hassle. I’m going to stay with Antergos now. Thank you for your help!

  • Glad you got it working. The best method to set your display settings varies depending on which Desktop you run. If it’s cinnamon/gnome you you can remove ~/.config/monitors.xml and then use the system settings tool to reset your resolution and that will make it stick. Of course, those settings are bound to your user account so wouldn’t affect the login screen.

    Best Regards,

Posts 5Views 1227
Log in to reply