• Adding plymouth

    How to add plymouth in cinnarch?

  • How to add plymouth in cinnarch?

  • I tried to add plymouth yesterday which took me down the “Figure it out out on linux” Rabbit Hole LOL
    Let me know if you get it working. I may give it another go this afternoon and if I’m successful I will update here.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Plymouth

  • Ok i tried in this way
    pacaur -S plymouth
    and i got the following

    :: Package(s) plymouth not found in repositories, trying AUR...  
    :: resolving dependencies...  
    :: looking for inter-conflicts...  
    :: plymouth-0.8.8-8 has been flagged out of date on 2013-05-18  
    AUR Packages (1): plymouth-0.8.8-8   
    :: Proceed with installation? [Y/n] y  
    :: View plymouth PKGBUILD? [Y/n] n  
    :: View plymouth .install script? [Y/n] n  
    [sudo] password for dinesh:   
    :: Building plymouth package...  
    ==\> Making package: plymouth 0.8.8-8 (Sun May 19 03:21:55 IST 2013)  
    ==\> Checking runtime dependencies...  
    ==\> Checking buildtime dependencies...  
    ==\> Retrieving sources...  
    -\> Downloading plymouth-0.8.8.tar.bz2...  
    % Total % Received % Xferd Average Speed Time Time Time Current  
    Dload Upload Total Spent Left Speed  
    100 1116k 100 1116k 0 0 14014 0 0:01:21 0:01:21 --:--:-- 14234  
    -\> Found arch-logo.png  
    -\> Found encrypt\_hook  
    -\> Found encrypt\_install  
    -\> Found gdm-plymouth.service  
    -\> Found kdm-plymouth.service  
    -\> Found kdm-unpatched-plymouth.service  
    -\> Found lightdm-plymouth.service  
    -\> Found lxdm-plymouth.service  
    -\> Found slim-plymouth.service  
    -\> Found plymouth.functions  
    -\> Found plymouth.initcpio\_hook  
    -\> Found plymouth.initcpio\_install  
    -\> Found plymouth-pid.patch  
    -\> Found plymouth-quit.service  
    -\> Found plymouth-quit-wait.service  
    -\> Found plymouth-set-default-theme.in.patch  
    -\> Found plymouth-update-initrd.patch  
    -\> Found plymouthd.conf  
    -\> Found system-release  
    -\> Found systemd-unit-dir.patch  
    -\> Found udevadm.patch  
    ==\> Validating source files with md5sums...  
    plymouth-0.8.8.tar.bz2 ... Passed  
    arch-logo.png ... Passed  
    encrypt\_hook ... Passed  
    encrypt\_install ... Passed  
    gdm-plymouth.service ... Passed  
    kdm-plymouth.service ... Passed  
    kdm-unpatched-plymouth.service ... Passed  
    lightdm-plymouth.service ... Passed  
    lxdm-plymouth.service ... Passed  
    slim-plymouth.service ... Passed  
    plymouth.functions ... Passed  
    plymouth.initcpio\_hook ... Passed  
    plymouth.initcpio\_install ... Passed  
    plymouth-pid.patch ... Passed  
    plymouth-quit.service ... Passed  
    plymouth-quit-wait.service ... Passed  
    plymouth-set-default-theme.in.patch ... Passed  
    plymouth-update-initrd.patch ... Passed  
    plymouthd.conf ... Passed  
    system-release ... Passed  
    systemd-unit-dir.patch ... Passed  
    udevadm.patch ... Passed  
    ==\> Extracting sources...  
    -\> Extracting plymouth-0.8.8.tar.bz2 with bsdtar  
    ==\> Starting build()...  
    -\> Setting a human-readable error for '\# plymouth-set-default-theme -R'  
    /tmp/pacaurtmp-dinesh/plymouth/PKGBUILD: line 49: patch: command not found  
    ==\> ERROR: A failure occurred in build().  
    :: plymouth cleaned  
  • You are still on the easy part! lol Are you using intel graphics? I think my problem has something to do with intel. If I am right then its going to install just fine. It just will lockup on boot until you kill it. (I was always able to switch VTs and kill plymouth, so no biggie) Anyways, for your current error just install the package called “patch” from PacmanXG and then proceed with plymouth! I’ll be checking this post often because I am curious to see if you get the same results!

  • I think it failed because you doesn’t have base-devel installed, that’s why it said “patch command not found”

    Install it with

    sudo pacman -S base-devel

    And try again

  • Hi.

    I have installed fbsplash and was working untill desktop becouse when X server started everything freez! didn’t have mouse, keyboard didn’t work… before I was using it on arch and was working fine so there is some problem with antergos…


  • Were you using this software in Arch with systemd?

    Looking at the AUR package it seems that it is not prepared to work with systemd, I see initscripts daemon

  • yes I was using fbsplash with archlinux x86_64 systemd, fully updated… and fbsplash was working fine, without any problems. Plymouth was making some problems with nvidia drivers (after login screen was blinking sometimes)…


  • I have installed patch and i have successfully installed plymouth and configured it based on their instructions but still plymouth not working

  • @"Dinesh said:

    I have installed patch and i have successfully installed plymouth and configured it based on their instructions but still plymouth not working

    Welcome to my world haha…I was hoping plymouth would work for you though! Are you using Intel graphics?

  • Ya i am an intel user

  • As am I, I think something with the plymouth package is not getting along with intel graphics. Ill update if I find out any solution!

  • Ok i am waiting to change the dark one to colorful plymouth

  • Update: I have managed to get plymouth up and running successfully! Just follow the configuration instructions here: [https://wiki.archlinux.org/index.php/PlymouthNow][0]">[https://wiki.archlinux.org/index.php/PlymouthNow][1]

    Now edit the file /usr/lib/systemd/system/yourDMhere-plymouth.service and ensure it includes these lines:

    After=systemd-user-sessions.service [email protected] plymouth-quit.service  
    Conflicts=plymouth-quit.service [email protected]  

    Also, /etc/usr/lib/systemd/plymouth-quit.service should include this line

    ExecStart=-/usr/bin/plymouth quit --retain-splash

    If you followed the wiki step by step and then made these changes you should have a working plymouth splash screen!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/PlymouthNow

Posts 15Views 6151
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.