• Ad-hoc not working


    Hi there,
    I’m trying to make an ad-hoc connection with nm-applet in mate desktop. the connection itself is created successfully, but it does not connect. and I get no errors to post in here.

    package dnsmasq is installed.
    kernel: 3.12.3-1-ARCH

    [b:2u2naw1p]Linux is not a software. Linux is a philosophy.[/b:2u2naw1p]

  • Hi there,
    I’m trying to make an ad-hoc connection with nm-applet in mate desktop. the connection itself is created successfully, but it does not connect. and I get no errors to post in here.

    package dnsmasq is installed.
    kernel: 3.12.3-1-ARCH

    [b:2u2naw1p]Linux is not a software. Linux is a philosophy.[/b:2u2naw1p]

  • How does it do without dnsmasq installed?

    If it works fine, then it must be something with your dnsmasq setup. If that’s the case, this should help:
    [url:wv2hjggx]https://wiki.archlinux.org/index.php/Dnsmasq[/url:wv2hjggx]

    The biggest thing is you will need ‘nameserver 127.0.0.1’ on the first line of your /etc/resolv.conf file.

    Then you will also need to run these two commands:

    systemctl enable dnsmasq  
    systemctl start dnsmasq
    

    Hope this helps, and please keep us informed.

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • excuse me for being late, I am very busy these days…
    and merry Christmas…

    actually I couldn’t make it work without dnsmasq, I read somewhere to install dnsmasq, but again there was no chance. so I removed dnsmasq.
    could you please tell me what should I‌ do, or what packages should be installed to get a working ad-hoc connection?

    [b:2u2naw1p]Linux is not a software. Linux is a philosophy.[/b:2u2naw1p]

  • the connection itself is created successfully, but it does not connect.

    Would you mind to give a little more explanation of what you mean by the above?

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • I right click on nm-applet > edit connections. Then I add a new wi-fi connection, then change the mode to Ad-hoc.
    and the rest of the settings are as defaults:
    wifi security: none
    ipv4: automatic (DHCP)

    Then I click on nm-applet > connect to hidden wi-fi network, and choose the connection I have made. nm-applet shows it’s trying to connect to that connection (the circle icon), but after a few seconds it stops and nothing has happened. then, when I look at the wifi list, that connection is listed there, but the wifi signal icon is gray.

    [b:2u2naw1p]Linux is not a software. Linux is a philosophy.[/b:2u2naw1p]

  • < >

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

Posts 8Views 1335
Log in to reply