• Gnome shell does not start


    I get a terminal.

    So i enter: gnome-shell --replace and i get this error:

    gnome-shell:699): clutter-CRITICAL **: Unable to initialize clutter: unable to open display. You have to set the DISPLAY environment variable, or use the --display command line argument
    mutter-warning unable to initialize clutter.

    I can find a work around by doing startx then gnome-shell --replace. but nothing looks quite right, and i want it to go back to normal. Any help?

  • Turn lightdm back on. sudo systemctl -f enable lightdm.

    You should see Gnome in the login manager :+1: .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • when I do the first command you gave, I see lightdm failed in red

  • @wintermadness Have you a log file for these error?

  • ● lightdm.service - Light Display Manager
       Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
       Active: failed (Result: start-limit) since Sun 2016-02-07 23:17:15 EST; 48s ago
         Docs: man:lightdm(1)
      Process: 733 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
     Main PID: 733 (code=exited, status=1/FAILURE)
    
    Feb 07 23:17:15 joes76 systemd[1]: Failed to start Light Display Manager.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Unit entered failed state.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Failed with result 'exit-code'.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
    Feb 07 23:17:15 joes76 systemd[1]: Stopped Light Display Manager.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Start request repeated too quickly.
    Feb 07 23:17:15 joes76 systemd[1]: Failed to start Light Display Manager.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Unit entered failed state.
    Feb 07 23:17:15 joes76 systemd[1]: lightdm.service: Failed with result 'start-limit'.
    
  • Hi,

    If I got you right, you boot into a terminal without X.

    You’re using lightdm, right? Check its logs (/var/log/lightdm)
    You should also check your system logs (sudo journalctl -xb)

    This could be many things. It was working before? Have you changed something (graphics related)?

    Cheers!

  • it was working before i didnt change anything

  • [+0.12s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.12s] DEBUG: Starting Light Display Manager 1.16.6, UID=0 PID=370
    [+0.12s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.12s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.12s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.12s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.12s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.21s] DEBUG: Registered seat module xlocal
    [+0.21s] DEBUG: Registered seat module xremote
    [+0.21s] DEBUG: Registered seat module unity
    [+1.16s] DEBUG: Monitoring logind for seats
    [+1.16s] DEBUG: New seat added from logind: seat0
    [+1.16s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+1.16s] DEBUG: Seat seat0: Starting
    [+1.16s] DEBUG: Seat seat0: Creating greeter session
    [+1.24s] DEBUG: Seat seat0: Creating display server of type x
    [+1.24s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
    [+1.24s] DEBUG: Using VT 7
    [+1.24s] DEBUG: Seat seat0: Starting local X display on VT 7
    [+1.24s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
    [+1.24s] DEBUG: DisplayServer x-0: Writing X server authority to /run/lightdm/root/:0
    [+1.24s] DEBUG: DisplayServer x-0: Launching X Server
    [+1.24s] DEBUG: Launching process 396: /usr/sbin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
    [+1.24s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
    [+1.24s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+1.24s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+1.83s] DEBUG: Loading users from org.freedesktop.Accounts
    [+1.83s] DEBUG: User /org/freedesktop/Accounts/User1000 added
    [+4.36s] DEBUG: Got signal 10 from process 396
    [+4.36s] DEBUG: DisplayServer x-0: Got signal from X server :0
    [+4.36s] DEBUG: DisplayServer x-0: Connecting to XServer :0
    [+4.36s] DEBUG: Seat seat0: Display server ready, starting session authentication
    [+4.36s] DEBUG: Session pid=425: Started with service 'lightdm-greeter', username 'lightdm'
    [+4.49s] DEBUG: Session pid=425: Authentication complete with return value 0: Success
    [+4.49s] DEBUG: Seat seat0: Session authenticated, running command
    [+4.49s] DEBUG: Session pid=425: Running command /usr/sbin/lightdm-webkit2-greeter
    [+4.49s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
    [+4.49s] DEBUG: Session pid=425: Logging to /var/log/lightdm/x-0-greeter.log
    [+4.75s] DEBUG: Activating VT 7
    [+4.75s] DEBUG: Activating login1 session c1
    [+4.75s] DEBUG: Seat seat0 changes active session to c1
    [+4.75s] DEBUG: Session c1 is already active
    [+9.34s] DEBUG: Session pid=425: Greeter connected version=1.16.6 resettable=false
    [+19.02s] DEBUG: Session pid=425: Greeter start authentication for joe
    [+19.02s] DEBUG: Session pid=642: Started with service 'lightdm', username 'joe'
    [+19.40s] DEBUG: Session pid=642: Got 1 message(s) from PAM
    [+19.40s] DEBUG: Session pid=425: Prompt greeter with 1 message(s)
    [+23.20s] DEBUG: Session pid=425: Continue authentication
    [+23.21s] DEBUG: Session pid=642: Authentication complete with return value 0: Success
    [+23.21s] DEBUG: Session pid=425: Authenticate result for user joe: Success
    [+23.21s] DEBUG: Session pid=425: User joe authorized
    [+23.21s] DEBUG: Session pid=425: Greeter requests session gnome
    [+23.21s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
    [+23.21s] DEBUG: Session pid=425: Sending SIGTERM
    [+23.84s] DEBUG: Session pid=425: Exited with return value 0
    [+23.84s] DEBUG: Seat seat0: Session stopped
    [+23.84s] DEBUG: Seat seat0: Greeter stopped, running session
    [+23.84s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
    [+23.85s] DEBUG: Session pid=642: Running command /etc/lightdm/Xsession gnome-session
    [+23.85s] DEBUG: Creating shared data directory /var/lib/lightdm-data/joe
    [+23.85s] DEBUG: Session pid=642: Logging to .xsession-errors
    [+24.13s] DEBUG: Activating VT 7
    [+24.13s] DEBUG: Activating login1 session c2
    [+24.14s] DEBUG: Seat seat0 changes active session to 
    [+24.14s] DEBUG: Seat seat0 changes active session to c2
    [+24.14s] DEBUG: Session c2 is already active
    [+16840.15s] DEBUG: Seat seat0: Locking
    [+16840.15s] DEBUG: Seat seat0: Creating greeter session
    [+16840.15s] DEBUG: Seat seat0: Creating display server of type x
    [+16840.15s] DEBUG: Using VT 8
    [+16840.15s] DEBUG: Seat seat0: Starting local X display on VT 8
    [+16840.15s] DEBUG: DisplayServer x-1: Logging to /var/log/lightdm/x-1.log
    [+16840.15s] DEBUG: DisplayServer x-1: Writing X server authority to /run/lightdm/root/:1
    [+16840.15s] DEBUG: DisplayServer x-1: Launching X Server
    [+16840.15s] DEBUG: Launching process 9526: /usr/sbin/X :1 -seat seat0 -auth /run/lightdm/root/:1 -nolisten tcp vt8 -novtswitch
    [+16840.15s] DEBUG: DisplayServer x-1: Waiting for ready signal from X server :1
    [+16840.23s] DEBUG: Seat seat0 changes active session to 
    [+16840.45s] DEBUG: Got signal 10 from process 9526
    [+16840.45s] DEBUG: DisplayServer x-1: Got signal from X server :1
    [+16840.45s] DEBUG: DisplayServer x-1: Connecting to XServer :1
    [+16840.46s] DEBUG: Seat seat0: Display server ready, starting session authentication
    [+16840.46s] DEBUG: Session pid=9535: Started with service 'lightdm-greeter', username 'lightdm'
    [+16840.47s] DEBUG: Session pid=9535: Authentication complete with return value 0: Success
    [+16840.47s] DEBUG: Seat seat0: Session authenticated, running command
    [+16840.47s] DEBUG: Session pid=9535: Running command /usr/sbin/lightdm-webkit2-greeter
    [+16840.47s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
    [+16840.47s] DEBUG: Session pid=9535: Logging to /var/log/lightdm/x-1-greeter.log
    [+16840.54s] DEBUG: Activating VT 8
    [+16840.54s] DEBUG: Locking login1 session c2
    [+16840.54s] DEBUG: Activating login1 session c3
    [+16840.55s] DEBUG: Seat seat0 changes active session to c3
    [+16840.55s] DEBUG: Session c3 is already active
    [+16840.79s] DEBUG: Session pid=9535: Greeter connected version=1.16.6 resettable=false
    [+16882.13s] DEBUG: Got signal 15 from process 1
    [+16882.13s] DEBUG: Caught Terminated signal, shutting down
    [+16882.13s] DEBUG: Stopping display manager
    [+16882.13s] DEBUG: Seat seat0: Stopping
    [+16882.13s] DEBUG: Seat seat0: Stopping display server
    [+16882.13s] DEBUG: Sending signal 15 to process 396
    [+16882.13s] DEBUG: Seat seat0: Stopping display server
    [+16882.13s] DEBUG: Sending signal 15 to process 9526
    [+16882.13s] DEBUG: Seat seat0: Stopping session
    [+16882.13s] DEBUG: Session pid=642: Sending SIGTERM
    [+16882.13s] DEBUG: Seat seat0: Stopping session
    [+16882.13s] DEBUG: Session pid=9535: Sending SIGTERM
    [+16882.19s] DEBUG: Session pid=9535: Terminated with signal 1
    [+16882.19s] DEBUG: Seat seat0: Session stopped
    
Posts 8Views 4683
Log in to reply