• \[SOLVED\] 64bit: Catalyst driver not working, fglrx problem


    Hi,

    shortly ago I was able to install and run Antergos 32bit on my laptop with a ATI Sumo graphics chip - Radeon HD 6… The solution to get it to work was to install the proprietary Catalyst driver by way of the respective Arch wiki page. That worked.

    I had to install Antergos 64bit version today, because I had forgotten about mem limits on 32bit – got 4 gb ram, only 2 gb were being recognised. So, I installed the 64bit version of Catalyst, worked through the how-to as before and this time it didn’t work.

    On non-quiet boot I get a failed to load kernel module error for which the fglrx module is the culprit as I found out. If I start lxdm from cli via systemctl, it, at first, looks like it might work, but then a screen says there has been a system error which could not be recovered. I presume that’s a result of the fglrx module not loading? The screen looks perfect by the way, no pixelation/distortions or whatever.

    Any idea without looking at logs? It’s almost midnight here and I need sleep, but wanted to post my question anyway. Will provide more info if necessary.

    Cheers

    Thorsten

  • Hi,

    shortly ago I was able to install and run Antergos 32bit on my laptop with a ATI Sumo graphics chip - Radeon HD 6… The solution to get it to work was to install the proprietary Catalyst driver by way of the respective Arch wiki page. That worked.

    I had to install Antergos 64bit version today, because I had forgotten about mem limits on 32bit – got 4 gb ram, only 2 gb were being recognised. So, I installed the 64bit version of Catalyst, worked through the how-to as before and this time it didn’t work.

    On non-quiet boot I get a failed to load kernel module error for which the fglrx module is the culprit as I found out. If I start lxdm from cli via systemctl, it, at first, looks like it might work, but then a screen says there has been a system error which could not be recovered. I presume that’s a result of the fglrx module not loading? The screen looks perfect by the way, no pixelation/distortions or whatever.

    Any idea without looking at logs? It’s almost midnight here and I need sleep, but wanted to post my question anyway. Will provide more info if necessary.

    Cheers

    Thorsten

  • Sorry I had not seen this before now. I’m sure you are asleep, possibly waking up soon LOL. You are correct the reason GNOME is throwing the fail whale screen is because of the kernel module not being loaded. The reason the screen doesn’t show signs of graphics problems is because its not using compositing which is required for gnome-shell. (Well, that might be an over simplified and less accurate explanation but you get the idea)…

    Did you do this: [https://wiki.archlinux.org/index.php/AMD_Catalyst#Loading_the_module_at_boot][0]">[https://wiki.archlinux.org/index.php/AM][1] … le_at_boot

    Also, did you install the “catalyst-hook” package from the AUR and enable it with systemd like it says here: [https://wiki.archlinux.org/index.php/AMD_Catalyst#Catalyst-hook][0]">[https://wiki.archlinux.org/index.php/AM][1] … alyst-hook It isn’t required but I recommend you install it, enable it, and then reboot. It will rebuild the module when the kernel is updated so you won’t have to worry about it.

    Hope that helps. Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/AM

  • Alright,

    it paid off to reread and redo the process from the wiki. My problem was that I had overlooked the part with the generation of the fglrx module with the respective kernel headers and, to add to it, forgot to initialise the xorg.conf via “aticonfig --initial” a few minutes ago. Corrected that.

    Now I’m in Antergos 64bit! Marking this solved, but got [b:3np4k9n9]a little question remaining[/b:3np4k9n9]:

    I’d like to use the catalyst-hook package to have the fglrx module auto-rebuilt after kernel changes, but it conflicts with catalyst-generator which depends on the installed kernel headers. So it seems I cannot remove catalyst-generator. To be honest, after just having made Antergos/Radeo run, I’m a bit hesitant to deinstall the kernel headers again, haha. Any advice appreciated. It’s no real biggy since I know how to manually rebuild the package, but humans are lazy, right?

  • Glad to hear you got it working!

    There is no reason to uninstall the kernel headers. It doesn’t hurt anything to leave them installed.

    Simply uninstall catalyst-generator and install catalyst-hook in its place. By all rights, catalyst-hook ‘should’

    Worst scenario would be to put it back the way you have it now to work it manually, if it doesn’t work automatically.
    Once you install catalyst-hook, enable it as per Dustin’s instructions above, and/or you can watch the install script as it should give you instructions on how to set it up so it runs properly.

    All the best!

    (Did I miss anything Dustin?)

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • Hi,

    I put it wrong: not the kernel headers need deinstalling, but catalyst-3.12-ARCH. That’s the catalyst package I had catalyst-generator build for me-

    This is my output when trying to install catalyst-hook. It’s in German, but I guess the meaning should be clear:

    $ sudo pacman -S catalyst-hook  
    Löse Abhängigkeiten auf...  
    Suche nach Zwischenkonflikten...  
    :: catalyst-hook und catalyst-generator stehen miteinander in Konflikt (catalyst). catalyst-generator entfernen? [j/N] j  
    Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)  
    :: catalyst-3.12-ARCH: benötigt catalyst-generator
    

    So, should I remove catalyst-3.12-ARCH, then install catalyst-hook and it will auto-build catalyst-3.12-ARCH again on shutdown/reboot? I’m a bit insecure about that right now.

  • So, should I remove catalyst-3.12-ARCH, then install catalyst-hook and it will auto-build catalyst-3.12-ARCH again on shutdown/reboot?

    It should! hehehe

    However, again, if not then you won’t lose anything. Uninstalling catalyst-generator will not lose the catalyst-3.12-ARCH pkg that was built. Nor will it uninstall/remove your modules it made and installed in the kernel. They should stay installed and running as normal. catalyst-hook will only work its job automatically when you install a new kernel.

    catalyst-3.12-ARCH should be stored in the /var/cache/pacman/pkg directory. You can check that first to make sure it is there. If it is there and you need to reinstall it simply run: sudo pacman -U /var/cache/pacman/pkg/catalyst-3.12*

    If you need to ask more, no problem. Dustin is here to help you!!

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • It’s not there in the cache, sadly. This feels a bit like a catch 22 situation:

    I have to remove the catalyst-3.12-ARCH package in order to deinstall catalyst-generator so I can install catalyst-hook. If things don’t work after reboot, I’ll have to remove catalyst-hook again in order to be able to build catalyst-3.12-ARCH with catalyst-generator, haha.

    Not trying this until Dustin hopefully pokes in and supports your advice.

  • Hey, no offense taken

    I haven’t installed that pkg so don’t know where it is stored, but you can uninstall catalyst-generator with this command:

    sudo pacman -R catalyst-generator --nodeps
    

    and it won’t touch your catalyst-3.12-ARCH file or what it has done for you.

    After that, you can install your catalyst-hook pkg and everything will be good to go after your next kernel upgrade.

    If you still want to wait for Dustin though, no problem, I couldn’t/wouldn’t blame you for that!

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • I tried to remove catalyst-generator with --nodeps, this is what it gave me

    [[email protected] ~]$ sudo pacman -R catalyst-generator --nodeps  
    [sudo] password for me:   
    Prüfe Abhängigkeiten...  
    Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)  
    :: catalyst-3.12-ARCH: benötigt catalyst-generator
    

    Even with --nodeps it still wants catalyst-3.12-ARCH

  • Ok, try this:

    sudo pacman -R catalyst-generator --nodeps --nodeps
    

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • OK,

    that worked! I’d done a web search for --nodeps, but couldn’t find the double argument and then you replied.

    Catalyst-hook automagically removed the fglrx module, then rebuilt it. After that, I enabled and started catalyst-hook via systemctl.

    systemctl enable catalyst-hook  
    systemctl start catalyst-hook
    

    Thanks a bunch!

  • Wonderful! Praise God!

    I’m sure Dustin is just totally laughing at how I went around in circles on this one! No problem Dustin! Have your laugh!!

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • You tried to help and succeeded. What more to ask for? Thanks, mate!

  • Thanks for your kind words and encouragement. A warm welcome to you my friend…and we can both say ‘Thanks, Mate’ to God (I don’t say this lightly) for His guidance and wisdom. How so full of love He is.

    May He continue to guide and bless you in your use and joy in using Arch/Antergos!

    And if you wish to help in a show of support, please consider clicking on Dustin’s link for Distrowatch once a day (sorry to mention if you already do). And also please leave Javascript on so that it will count.

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • @“MaNNa”:202jib9x said:

    Wonderful! Praise God!

    I’m sure Dustin is just totally laughing at how I went around in circles on this one! No problem Dustin! Have your laugh!!

    Who? Me? …Nah!

    I am smiling though! It’s great when everyone helps each other. As for what caused the issue, I really can’t say. Nothing requires catalyst-generator so its weird that you got that error. You guys figured it out though so that’s all the matters

    Just a little FYI… “pacman -Rdd” = “pacman -R --nodeps --nodeps”

    Cheers!

  • @“lots.0.logs”:2vxtpxhl said:

    Just a little FYI… “pacman -Rdd” = "pacman -R --nodeps --nodeps"
    LOL, damn you

    Cheers!

  • “pacman -Rdd” = “pacman -R --nodeps --nodeps”

    Ya, I knew that!

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

Posts 18Views 4012
Log in to reply