• Antergos won't load DE after install


    I installed Antergos on my laptop, which is an msi cx61 2PC, after facing some problems with cnchi. First I installed it with the latest stable version of cnchi, but then noveau would crash the boot. I installed again with the dev release of cnchi, which allows the installation of privative graphics drivers, but now it won’t load the DE (GNOME in my case) on boot.

    My laptop has 2 video cards, integrated intel and an Nvidia GeForce 820M, so I’m guessing it has to do with the video drivers for the Nvidia.

    I can login into a TTY, I just don’t know what to do to fix this problem. Typing startx fails, tells me there are no screens to attach to.

    Help, please?

  • @HaPK

    Hi,
    Try nomodeset o boot menu options.

  • @aleqwerty24 could you tell me how please?

  • nomedeset doesn’t fixes this, apparently it does nothing.

    Checking the xorg logs it loads the NVidia drivers but then it says that no devices were found, so I’m guessing it has to do with those drivers.

  • Insatlled bumblebee to see if it would solve the problem but I’m still stuck without a DE.

    A few “screenshots” of logs and the such
    a few commands
    cat /var/log/Xorg.0.log

  • I also get no DE at boot. I installed Antergos 32 bit XFCE a month ago and it works fine. Today I installed Antergos 64 bit twice, once with Cinnamon, once with XFCE. Automatic logon was selected and I’ve verified the settings are present in /etc/lightdm/lightdm.conf. LightDM but it boots to the greeter. A manual login makes the screen flash like LightDM tries to launch the DE but it returns to the greeter with a new background picture.

    What I can do is Ctrl-Alt-F2, log in as user.

    sudo systemctl stop lightdm
    startxfce4
    

    That produces a desktop, but LightDM won’t.


    I found it. The lightdm updates keep supplying new copies of lightdm.conf.pacnew. Comparing those to the original showed a part missed by the Antergos installer. Fixing this line described in the Arch Linux LightDM Autologon makes the desktop appear as it should.

    /etc/lightdm/lightdm.conf
    session-wrapper=/etc/lightdm/Xsession
    
  • This post is deleted!
  • Ok, it looks like I fixed it. I changed LightDM for GDM and I can finally use my DE. But now I have to use Wayland (which is awesome, I’m using the future!), nice but slightly buggy, and also I can’t do stuff like opening GUI applications as root from the terminal (e.g. sudo gedit). But that is something for another ask.

    So, what I did was exactly this:

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl stop lightdm
    sudo systemctl enable gdm
    sudo systemctl start gdm
Posts 9Views 2084
Log in to reply