• Like 0

    Downgrade kernel - Antergos Freezes


    Hi there

    I have a Dell Inspiron with a Intel N3540 which is suffering from this bug: https://bugzilla.kernel.org/show_bug.cgi?id=109051

    I came from Ubuntu 14.04 so the kernel was quite old and It did not show this problem.

    I would not like to use the suggested fix:

    This originally started as a gpu regression report against a change to the turbo logic. After much random walking reporter consensus seems to have settled on max_cstate=1 as the one true workaround

    Because of this:

    but intel_idle.max_cstate=1 would result in seriously increased power consumption?!

    So, the only really fix for me is this:

    first of all, for me the intel_idle.max_cstate=1 solution didnt work for me either, but i said that earlier already.

    to you guys disabling hardware acceleration with the info from arch-wiki.
    why do you disable hardware acceleration if you can just install any 4.1 kernel (i use 4.1.12) and at the same time use hardware acceleration and dri, without any system freezes ?
    it seems to me the much better solution.

    So, my question is: how can I downgrade to that kernel considering that my install is a new clean install and I do not any old packages on my machine ?(I have already read the documentation on Arch Wiki about this) Where can I download the needed packages from? What are the steps to safely downgrade the kernel, should I do it booting up with a media antergos live USB?

    Thanks!

  • Like 0

    You can find the older kernel and kernel modules here: https://archive.archlinux.org/packages/l/

    Then follow https://wiki.archlinux.org/index.php/Downgrading_packages#Downgrading_the_kernel

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Like 0

    Done and running perfectly after the downgrade.

    Thanks.

Posts 3Views 622
Log in to reply