• New Pamac not starting


    I updated the system this morning along with the new pacman.
    Now, when I try to open it (add/remove software graphical), it stays rotating for a while in the panel then disappears.
    Should I set something up to make the new pacman work?

    Antergos KDE + Antergos XFCE + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • Hi,

    There were a few breaking changes (albeit small) that require Pamac’s (the GUI package manager) code to be updated. I don’t expect it will take very long for Pamac’s developers to release an update. You can monitor the situation over on github [here].(https://github.com/manjaro/pamac/issues/90).

    Cheers!

    PS> Just so you know…pacman is a command line application. It has no GUI. The GUI package manager is simply a frontend to pacman. Its not affiliated with pacman (different developers).

  • Ok, thank you for telling me.
    I was wondering if it was just a problem of mine.

    Antergos KDE + Antergos XFCE + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • The same goes for pacman, too, though…
    $ yaourt -Syyua
    package-query: error while loading shared libraries: libalpm.so.9: cannot open shared object file: No such file or directory

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • It sure is!:laughing:
    Just wanted to make it clear, because the post was actually on pamac and not pacman.
    A few minutes ago, there was another post (you probably saw it) asking if there was a possibility of using a CLI package manager to have more control on the system.
    So, considering this plus your answer to this post, I wanted to make clear that if pamac does not work, then, no other (CLI/GUI) will work…:facepunch:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • For the time being I downgraded pacman back to 4.2 (for which pamac’s GUI works).
    If you want that too just:

    sudo pacman -U /var/cache/pacman/pkg/pacman-4.2.1-4-x86_64.pkg.tar.xz
    

    (unless you cleaned your cache since the update to pacman 5)
    * in case you had another version (e.g different architecture for different hardware), just check what older pacman version you do have and choose it instead.

    If you’re unsure whether or not to do it or you have a different problem, consult the documentation: https://wiki.archlinux.org/index.php/downgrading_packages

  • @anarch right but to make it even more clear, it should be noted that pacman will work fine when called directly on the command line. Cheers!

  • He, he, heh…could not argue on the clarity of this, could I?
    :sweat_smile:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @lots.0.logs would you like me to change my post so there’s no room for misunderstanging?

    Antergos KDE + Antergos XFCE + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • @anarch :laughing:

    @fabio Good idea…I’ll take care of it. Thanks!

  • Any news about that update? On github I don’t see any progress.

  • I’m also having this issue. When I go to “Add/Remove Software” (Pamac) in my apps menu and execute it, it looks like it’s about to start, but then closes. Getting the same error in Konsole: “package-query: error while loading shared libraries: libalpm.so.9: cannot open shared object file: No such file or directory”. :/


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • @saoded , when I try to downgrade, Konsole reports this error:

    warning: downgrading package pacman (5.0.0-1 => 4.2.1-4)
    resolving dependencies…
    looking for conflicting packages…
    error: failed to prepare transaction (could not satisfy dependencies)
    :: packagekit: installing pacman (4.2.1-4) breaks dependency ‘pacman>=5.0.0’

    Any suggestions?


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Ive updated this package and it got fixed: https://aur.archlinux.org/packages/package-query/
    Seems that antergos repositories are not up to date with that package. (they both have the same version number but not same edition date)

    That worked for me in yaourt and pacman, no more libalpm.so missing errors
    Hope antergos repos get an update soon =)

  • @Antas How to use the package-query from Arch repos? I did pacman -Su package-query but I still can’t use yaourt.

  • @Antas , run these two commands in terminal or Konsole:

    wget “https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=package-query” -O PKGBUILD
    makepkg -sri

    This fixes yaourt, but pamac, both software manager and software updater, still doesn’t work. :/


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • @saoded said:

    For the time being I downgraded pacman back to 4.2 (for which pamac’s GUI works).
    If you want that too just:

    sudo pacman -U /var/cache/pacman/pkg/pacman-4.2.1-4-x86_64.pkg.tar.xz
    

    (unless you cleaned your cache since the update to pacman 5)
    * in case you had another version (e.g different architecture for different hardware), just check what older pacman version you do have and choose it instead.

    If you’re unsure whether or not to do it or you have a different problem, consult the documentation: https://wiki.archlinux.org/index.php/downgrading_packages

    I can confirm this method worked for me Cheers!

  • @runrickus said:

    @saoded said:

    For the time being I downgraded pacman back to 4.2 (for which pamac’s GUI works).
    If you want that too just:

    sudo pacman -U /var/cache/pacman/pkg/pacman-4.2.1-4-x86_64.pkg.tar.xz
    

    (unless you cleaned your cache since the update to pacman 5)
    * in case you had another version (e.g different architecture for different hardware), just check what older pacman version you do have and choose it instead.

    If you’re unsure whether or not to do it or you have a different problem, consult the documentation: https://wiki.archlinux.org/index.php/downgrading_packages

    Turns out this also worked for me. I had to uninstall “simple-scan” and “packagekit” to resolve dependency issues, but it worked.


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • This seems to be fixed now!:smile:
    "pacman -Q pamac pacman
    pamac 2.4.3-6.1
    pacman 5.0.0-1
    "
    Kind regards

Posts 33Views 10556
Log in to reply