• Lan Messenger: no tray icon, no settable sounds.


    I install the “lmc v. 1.2.35-2” (Lan Messenger), but I have found that the tray icon is missing. The place of the icon is occupied, but no symbol in it. Another flaw is that the audio is not detected and the check button under the alarm menu is not settable.

    All relevant information is appreciated.

  • @flanto What theme are you using?
    Have you switched themes? That may be the problem.

  • So, I have tried both the standard theme (Adwaita), that several other themes and icons, in all parameters: GTK + theme, icons theme and Gnome Shell theme. None solution worked. But the most annoying thing is the lack of sound and the impossibility to set them in the preferences menu. In each case the same thanks for your cooperation.

  • It sounds more of a case of a bug that should be reported to the developers.
    Try installing it on an older version of Gnome (maybe use a virtual machine for that). It could be a Gnome related problem.
    Also you can try installing a different DE on your system and test it out.

  • @joaojotta It’s a bug from gnome shell, some thime the icons don’t appear when i init session, some time appear after a time or when un suspend the session, some times when i reboot the pc, it’s estrange, really.

  • gtk-update-icon-cache /usr/share/icons/PATHTOTHEME
    Maybe?

  • So, I tried to update the cache, First I tried to find the icons of LAN Messenger:

    [[email protected] ~]$ find /usr/share/icons/* -regex ‘.*?lmc.*?’
    /usr/share/icons/hicolor/22x22/apps/lmc.png
    /usr/share/icons/hicolor/24x24/apps/lmc.png
    /usr/share/icons/hicolor/16x16/apps/lmc.png
    /usr/share/icons/hicolor/36x36/apps/lmc.png
    /usr/share/icons/hicolor/48x48/apps/lmc.png

    Then I run the command you suggested (w/sudo privileges and --force option):

    sudo gtk-update-icon-cache -f /usr/share/icons/hicolor

    This actually update “icon-theme.cache”, but this not solve missing icon. I investigate on other icons type that are resident in notify, and I discovered that is of Scalable Vector Graphics (".svg") types… Perhaps this could be the reason? LAN Messenger has only “.png” icons type…
    However the issue of the missing sound, I did not find anything about it on the internet. The only question that comes to me is that my notebook has 2 audio outputs and perhaps LAN messenger fails to recognize the main audio card … I don’t know …

    Regards…

lan2 icon32 sound44 messenger1 missing28 Posts 7Views 1449
Log in to reply