• Screen Timeout


    After installation on my laptop, the screen does not timeout. I couldn’t find anything in settings to enable it. I did a google search and came across a program named ‘x-screensaver’ which sort of works the way I wanted. Instead of a total shutdown of the screen after the timeout, the screen is slightly lit while blacked out.

    Is there another solution that will help me achieve total screen shutoff after the specified timeout period?

  • After installation on my laptop, the screen does not timeout. I couldn’t find anything in settings to enable it. I did a google search and came across a program named ‘x-screensaver’ which sort of works the way I wanted. Instead of a total shutdown of the screen after the timeout, the screen is slightly lit while blacked out.

    Is there another solution that will help me achieve total screen shutoff after the specified timeout period?

  • Are you using the default GNOME desktop? I think I remember reading posts about this particular feature setting being absent. I am not sure b/c I switched to Cinnamon so it has been a while since I used GNOME. In Cinnamon its adjustable in System Settings>Screensaver & Lock Screen

    Sorry I couldn’t be of more help but its an issue with the way GNOME works. As for getting xscreensaver to do what you want, check this out: [https://wiki.archlinux.org/index.php/Display_Power_Management_Signaling#xset_DPMS_settings_do_not_work_with_xscreensaver][0]">[https://wiki.archlinux.org/index.php/Di][1] … creensaver

    Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Di

  • Thank you for your speedy response. I will give Cinnamon a shot. Is it possible that if the screen timeout is setup in Cinnamon that it would take effect within gnome?

  • I’m not sure but honestly I doubt it. I looked at the dconf settings for both gnome and cinnamon and the funny thing is I could not find the setting in either. Perhaps cinnamon is handling that setting some other way (which is why it probably won’t affect GNOME).

    Best Regards,

  • So good news! I setup up the timeout settings within Cinnamon and then logged out and into Gnome. The timeout is now working without x-screensaver. I did notice that that the option within Cinnamon to enable the timeout settings is in the advanced view from within the settings console. This option is not available for me in gnome.

  • Well that’s good news then. As far as the setting not available in GNOME, it has nothing to do with you or your system. It’s been happening a lot as GNOME is still in a transitional phase of development. I prefer Cinnamon to GNOME mostly because of all the options that have been made unadjustable in GNOME. BUT I digress…lol Let us know if you have any other questions!

    Cheers!

  • Thank you for your response. You led me to the solution. Look forward to watching the development on this.

  • You are most welcome!

Posts 9Views 1679
Log in to reply