• [Solved] [GEMS] Can't execute them, might be at the wrong place?


    Hello,

    Since now 5 months, I am using Antergos in a daily basis without having to complain. I like rollings that does not mess up for upgrading badly and albeit I do like user-friendly systems, there are sometimes blocking mistakes. :sweat:

    I have as a project to built from ground up a website using Twig and Sass, so the code is easier to maintain. To use Sass, I have to install it with gem install sass. While it installs without any problem, I can’t execute the code. Here how it’s happenning:

    [[email protected] /]$ gem install sass
    WARNING:  You don't have /home/krands/.gem/ruby/2.3.0/bin in your PATH,
    	  gem executables will not run.
    Successfully installed sass-3.4.21
    Parsing documentation for sass-3.4.21
    Done installing documentation for sass after 3 seconds
    1 gem installed
    

    I have the very same error using sudo gem install sass, but the path is different: /root/.gem/ruby/2.3.0/bin.
    As I know that Antergos is a Archie’s fork, I though it was a good idea to look at the latter’s wiki.
    The first paragraph of the link is mentioned as this:

    By default in Arch Linux, when running gem, gems are installed per-user (into ~/.gem/ruby/), instead of system-wide (into /usr/lib/ruby/gems/). This is considered the best way to manage gems on Arch, because otherwise they might interfere with gems installed by Pacman.

    I also looked in the Antergos’ wiki, Ruby is not mentioned, even with a search. :disappointed:

    Why can I install gems if I can’t execute them? Then, is there any way to move the folder properly to the correct one, so I could execute gems? :confused:

  • Apparently, anything you do with Ruby requires a reboot to function.

    I am sorry.

    Cheers! :beers:

  • Put Solved, don’t Resolver man :D

resolved1 Posts 3Views 2865
Log in to reply