• Slow bootuptime


    Hi

    my system is booting up very slow eversince i installed sometimes i thought it got even slower. - but i really need like 3 mins for booting up min.
    I have btrfs and everything encryptet so i need to typ in the pw for the partition 3 times, but thats not the main thing that eats time it takes definitely forever after i unlocked the last partition.

    ok i just today randomly found the systemd-analyze queries

    systemd-analyze time
    Startup finished in 12.128s (kernel) + 2min 27.464s (userspace) = 2min 39.593s
    

    and as with everything not running smooth in antergos lightdm seems to be the one to blame.

    stemd-analyze blame
             50.474s lightdm.service
             32.137s NetworkManager-wait-online.service
             28.813s man-db.service
             21.389s mnt-xxx\xxxx.mount
              8.816s [email protected]
    ...
    

    and there is some loss by mounting network shares but that is my fault.
    It is also quiet fast at tty and then randomly waits for up to 30 seconds doing nothing visible before it starts cinnamon-session.

    so mainquestion any ideas about what to to with the 50 sec of lightdm?

    thanks

  • @fjsdiolk there are similar questions on both the Arch and Ubuntu forums. Take a look at /var/log/lightdm/lightdm.log if it exists and check where the bottleneck is.

  • Hi thanks for the anwer :)

    here is my log

    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.16.6, UID=0 PID=777
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.00s] DEBUG: Registered seat module xlocal
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.01s] DEBUG: Monitoring logind for seats
    [+0.01s] DEBUG: New seat added from logind: seat0
    [+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
    [+0.01s] DEBUG: Seat seat0: Starting
    [+0.01s] DEBUG: Seat seat0: Creating user session
    [+0.27s] DEBUG: Loading users from org.freedesktop.Accounts
    [+0.27s] DEBUG: User /org/freedesktop/Accounts/User1000 added
    [+0.33s] DEBUG: Seat seat0: Creating display server of type x
    [+0.33s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
    [+0.33s] DEBUG: Using VT 7
    [+0.33s] DEBUG: Seat seat0: Starting local X display on VT 7
    [+0.33s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
    [+0.35s] DEBUG: DisplayServer x-0: Writing X server authority to /run/lightdm/root/:0
    [+0.35s] DEBUG: DisplayServer x-0: Launching X Server
    [+23.57s] DEBUG: Launching process 798: /usr/sbin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
    [+23.57s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
    [+23.57s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+23.57s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+107.32s] DEBUG: Got signal 10 from process 798
    [+107.32s] DEBUG: DisplayServer x-0: Got signal from X server :0
    [+107.32s] DEBUG: DisplayServer x-0: Connecting to XServer :0
    [+108.68s] DEBUG: Seat seat0: Display server ready, starting session authentication
    [+108.68s] DEBUG: Session pid=809: Started with service 'lightdm-autologin', username 'XXXXX'
    [+109.11s] DEBUG: Session pid=809: Authentication complete with return value 0: Success
    [+109.11s] DEBUG: Seat seat0: Session authenticated, running command
    [+109.11s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
    [+109.12s] DEBUG: Session pid=809: Running command /etc/lightdm/Xsession cinnamon-session-cinnamon
    [+109.12s] DEBUG: Creating shared data directory /var/lib/lightdm-data/XXXXX
    [+109.12s] DEBUG: Session pid=809: Logging to .xsession-errors
    [+109.63s] DEBUG: Activating VT 7
    [+109.63s] DEBUG: Activating login1 session c1
    [+109.63s] DEBUG: Seat seat0 changes active session to c1
    [+109.63s] DEBUG: Session c1 is already active
    [+41425.57s] DEBUG: Seat seat0 changes active session to
    [+41429.34s] DEBUG: Seat seat0 changes active session to c1
    [+41429.34s] DEBUG: Session c1 is already active
    [+61680.33s] DEBUG: Seat seat0 changes active session to
    [+61683.63s] DEBUG: Seat seat0 changes active session to c1
    [+61683.63s] DEBUG: Session c1 is already active
    

    i mostly don’t understand it i just see two big “waiting-times.”.
    from .35s to 23 and from 23.57s to 107s

  • ok and i just checked the config of lightdm

    auto login is set to my user and timeout is 0…
    (https://wiki.ubuntu.com/LightDM)

  • btw. have you got any link to any thread someone yould fix it?

performance7 boot182 lightdm97 Posts 5Views 926
Log in to reply