• wifi not found by installation


    this is not new, I know but nothing that I found works for me. I have Acer Aspire small notebook with a Broadcom wifi interface. The network applet does not see it. ip link returns loopback 0. That’s about it. The kernel driver is bcma. I tried modprobe -r bcma then modprobe broadcom and modprobe bcma. Nothing helps. Could someone help me?

  • Please, so we know exactly which interface chip you have, can you issue a lspci -nn and post the results here?

    Thanks!

  • this is the answer to lspci -nn: (I just left the network chips):

    00:18.7 Host bridge [0600]: Advanced Micro Devices, Inc. [AMD] Family 12h/14h Processor Function 7 [1022:1719]
    06:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
    07:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
    Thanks

    Atheros

  • Aha, Atheros works and can be seen by the system, Broadcom does not.

  • I too have an Acer Aspire One netbook with a Broadcom adapter. What has worked for me is to install the ‘broadcom-wl’ package which I believe is available in the local repositories. You will need to connect to the router via an ethernet cable to perform this action. I’ve also noticed I need to re-install this package after updates to the Network related software.
    I hope this works for you.
    SJ

  • @sjohri this worked for me but it also required removing the other running units and modprobe wl

  • Hi SJohri,

    thanks for your help. I did as you wrote and wifi started to work. Afterwards I looked it up in the Arch forum and they had it solved for a long time. It seems that every Mac Book has one or other Broadcom chip so it was a big problem.
    Thanks again for your help.

    michal

  • @michal If you believe that the question has been answered, would you like to mark the topic as [Solved]? You can find it under topic tools in your first post or at the bottom of this page.

    Thanks 👍 .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn thanks for the info Wyn. I was wandering how to change the status. It is done.
    Thanks

Posts 9Views 2224
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.