• Pacman no instala ni actualiza


    Hola:
    Al tratar de instalar o actualizar, me sale el siguiente texto:
    “gpg: hase comproba-la base de datos de confianza o 2017-01-01
    [[email protected] pacman]# sudo pacman -Syy
    :: Sincronizando as bases de datos de paquetes…
    Produciuse un erro: error ao actualizar core (non se puido bloquear a base de datos)
    Produciuse un erro: error ao actualizar extra (non se puido bloquear a base de datos)
    Produciuse un erro: error ao actualizar community (non se puido bloquear a base de datos)
    Produciuse un erro: error ao actualizar antergos (non se puido bloquear a base de datos)
    Produciuse un erro: non se puido sincronizar nungunha base de datos
    Produciuse un erro: error ao iniciar a transacción (non se puido bloquear a base de datos)
    Produciuse un erro: Non foi posíbel reservar a base de datos: O ficheiro xa existe
    se está seguro que non se está executando un administrados de paquetes, pode eliminar /var/lib/pacman/db.lck.”

    He probado varias soluciones del foro y no encuentro una que funcione. Por otra lado busqué lo que me indica la última línea y ese archivo no lo tengo.

    Gracias y un saludo

    David

  • @romeroqueiruga said:

    /var/lib/pacman/db.lck

    Cierra pamac, octopi, cualquier actualizador de paquetes que tengas instalado.
    Borra el fichero de lock:
    rm /var/lib/pacman/db.lck

    Ejecuta pacman:
    sudo pacman -Syyuu

    Saludos!

  • @karasu Gracias, justo le había dado para que reiniciara y ahí sí. Ahora peleándome con las keys que fallan. Je je. Disculpa las molestias.

update55 paccman1 Posts 3Views 1556
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.