• System Suspends far too often


    Been using Arch a few years, gone through a few dozen installs it seems like across 4 devices… Antergos is a BIG WELCOME to automating the installation! THANK YOU! The entire house is almost now completely on Antergos! (27" iMac Retina and Surface 3 giving me some grief, almost done though).

    Now that I’ve buttered ya up…

    I have an annoying problem after installing Antergos on two systems: the system will ‘suspend’ during odd actions of using the system. Here are some examples:

    • Within Gnome and selecting “Log Out”, the system goes into Suspend immediately.
    • When only “Blank Screen” is set in Gnome, the system goes into Suspend when the screen blank timeout occurs.
    • Disabling all timeouts, screen blanks, etc - the system will still go into standby sometime in the middle of the night.

    Another annoyance that happens 1/2 the time when it wakes up from any of the above actions:

    • When waking up from Suspend, sometimes it goes right back into Suspend a few seconds later. Waking up a 2nd time stays awake.

    I’ve noticed when this happens, the first time I “wake it up” the screen is not locked - it immediately shows my desktop and I can move the mouse… until it suspends again. On the 2nd wake up, now the screen is locked with GDM’s lockscreen/signin.

    This may be an indication that I have two services attempting to “suspend” the system. But, i can’t seem to find what is triggering them in the logs.

    I’ve used dconf-editor and modified:

    • org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 900
    • org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type blank

    Which is suppose to “blank the screen.” But instead, it forces the system into sleep.

    If I change this to “Nothing” and set the timeout to “0”, the system stays awake but still goes into suspend in the middle of the night sometime.

    I have removed “Light Locker” thinking that was the blame; but, it doesn’t seem to have changed anything.

    I should note that I had to remove lightdm and install GDM instead, to use with Gnome. This is because of its touchscreen, onscreen keyboard and PIN ability - which goes well with our tablets. I recall GDM having some power settings; but, i can’t seem to find them - or at least, any that are enabled.

    Again, I think I have two competing suspending solutions with a default Antergos install. Any help would be appreciated.

  • Just a thought, check that you’re not using light locker…

  • @karasu said:

    Just a thought, check that you’re not using light locker…

    Maybe u were posting this as I was editing the post above… 👍 …to say I had already removed Light Locker earlier. That’s not the cause of this.

    Unless Light Locker’s removal script leaves behind some artifacts, like a systemd service.

    $ grep -rni “light” /usr/lib/systemd/system/*

    Didn’t show anything named Light Locker or anything.

    I think it’s GDM but I haven’t been able to find any settings for it.

gnome328 suspend46 powermanagement12 gnome310 Posts 3Views 1236
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.