• pm2ml missing dependency


    The pm2ml package (used by powerpill) now also depends on python3-xcgf, but the latter is not present in the Antergos repository (nor any of the official Arch ones). Could you please add it? Otherwise, powerpill should get removed.

    Thanks,
    oggy

  • @oggy said:

    The pm2ml package (used by powerpill) now also depends on python3-xcgf, but the latter is not present in the Antergos repository (nor any of the official Arch ones)…

    python3-xcgf is present in AUR.

    $ yaourt python3-xcgf
    1 aur/python3-xcgf 2016.1-1 (30)    Xyne's common generic functions, for internal use.                                                                                                                              
    ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
    ==> -------------------------------------------------------
    ==>
    $ 
    

    pm2ml is preesnt in two different repos. Probably you need to install the one from AUR.

    $ yaourt pm2ml
    1 antergos/pm2ml 2016.1-1
        Generate metalinks for downloading Pacman packages and databases.
    2 aur/pm2ml 2016.1-1 (120)
        Generate metalinks for downloading Pacman packages and databases.
    ==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
    ==> -------------------------------------------------------
    ==>                                                                                                                                   $ 
    
  • Hi just, thanks for the reply! Yes, it’s present in AUR, I switched to that one. But IMHO then the one in the Antergos repos should be removed (together with powerpill), or the dependencies should be pulled in. Anyway, I just wanted to point the problem out.

  • @oggy Agree with you. The same package presence in two different repos is a strange thing. To say the least.

Posts 4Views 608
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.