• \[SOLVED\] System hangs after boot


    [b:2kz1sfsi]Edit:[/b:2kz1sfsi] The solution for my system was to install the ATI Catalyst driver instead of the opensource driver.

    Hi,

    just installed Antergos on my laptop after checking it out in a Virtualbox. Install from USB went okay after a bit of tweaking, but after booting, the system sits at a certain point, see attached picture, goes black once then returns to that mentioned screen.

    Seems there is a UMS problem with the radeon card, too. When I boot with nomodeset, an error message is additionally displayed: “drm:radeon_init ERROR No UMS support in radeon module!”

    Got a Samsung dualcore laptop with a Radeon card (HD 6480G, the opensource driver is installed). If you need more details, please let me know so I know what to provide.

    [b:2kz1sfsi]Edit[/b:2kz1sfsi] I’m currently on [https://wiki.archlinux.org/index.php/ATI][0]">[https://wiki.archlinux.org/index.php/ATI][1] to check out possible solutions.

    Thorsten

    NB the picture’s file name is probably not correct, I don’t know if there really is a “loop”

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/ATI

  • [b:2kz1sfsi]Edit:[/b:2kz1sfsi] The solution for my system was to install the ATI Catalyst driver instead of the opensource driver.

    Hi,

    just installed Antergos on my laptop after checking it out in a Virtualbox. Install from USB went okay after a bit of tweaking, but after booting, the system sits at a certain point, see attached picture, goes black once then returns to that mentioned screen.

    Seems there is a UMS problem with the radeon card, too. When I boot with nomodeset, an error message is additionally displayed: “drm:radeon_init ERROR No UMS support in radeon module!”

    Got a Samsung dualcore laptop with a Radeon card (HD 6480G, the opensource driver is installed). If you need more details, please let me know so I know what to provide.

    [b:2kz1sfsi]Edit[/b:2kz1sfsi] I’m currently on [https://wiki.archlinux.org/index.php/ATI][0]">[https://wiki.archlinux.org/index.php/ATI][1] to check out possible solutions.

    Thorsten

    NB the picture’s file name is probably not correct, I don’t know if there really is a “loop”

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/ATI

  • Hi,

    Try removing the “quiet” kernel command and adding the one below. When grub starts press “e” and find the line that starts with “linux /boot/vmlinuz-linux” replace “quiet” with:

      
    Press F10 to continue and you should end up at a terminal log in screen.  
      
    After you log in you check the logs for clues as to exactly what is wrong. Use these commands:sudo journalctl -b  
    sudo nano /var/log/Xorg.0.log
    

    If nothing stands out and you would like another pair of eyes to review the log, just post them here. (Save journal to a file using: “sudo journalctl -b > ~/journal.log”

    Cheers!

  • Hi Dustin,

    and thanks for your help so far.

    I was able to reach that login prompt and had a look at both log files. I can’t make much sense of either, so it would be kind of you to glance over them. The forum software denied .log and .txt files so I’m pointing you to my dropbox:

    [https://www.dropbox.com/s/4f49q8tjgwa61o9/Xorg.0.txt][0]">[https://www.dropbox.com/s/4f49q8tjgwa61o9/Xorg.0.txt][1]

    [https://www.dropbox.com/s/27kwnsciuen3qfu/journal.txt][0]">[https://www.dropbox.com/s/27kwnsciuen3qfu/journal.txt][2]

    Any help, even RTFM <point to read up stuff> is appreciated!

    Cheers!

    [0]: <a href=
    [1]: https://www.dropbox.com/s/4f49q8tjgwa61o9/Xorg.0.txt
    [2]: https://www.dropbox.com/s/27kwnsciuen3qfu/journal.txt

  • Hmmm…Everything seems normal in the logs you posted. Your radeon card even looks to be working like it should. This is likely because booting with the commands I posted is either bypassing the issue or not taking the system far enough for it to present itself. Try removing “quiet” like before but don’t add anything else then see what errors are displayed. Once you think the system has become unresponsive, try switching terminals (Ctrl+Alt+F2). If you are successful, grab the logs again and they should show what’s caused the hang up. If you aren’t able to get over to another terminal, try repeatedly pressing the key sequence immediately after you tell grub to continue. Also, if you are still stuck and waiting for a reply from me, it’s a good idea to boot again using the commands from my previous post and then update the system with 'sudo pacman -Syyu". Sometimes that is all it takes to fix things (if luck is on your side hehe)

    Best Regards,

  • Alright,

    I updated the system to the latest files, to no avail though.

    I booted without “quiet”, would you care to look over the logs again?

    [https://www.dropbox.com/s/95bzwvquh2syw0h/journal_new.log][0]">[https://www.dropbox.com/s/95bzwvquh2syw][1] … al_new.log

    [https://www.dropbox.com/s/86dnljr7n9ywbj3/Xorg.0.new.log][0]">[https://www.dropbox.com/s/86dnljr7n9ywb][2] … .0.new.log

    Edit: Still stuck at [OK] graphical target reached. After reinstalling the x86-video-ati and installimg xorg-xinit package for the startx command, I’m getting a black or pixelated screen after startx. Can’t switch to other virtual terminals anymore then. Something else I noticed is that after a while the screensaver seems to kick in, the result being a pixelated colourful screen also.

    I keep researching the issue and keep reading wiki pages plus other arch forums and trying out solutions. This is becoming a little frustrating at the moment since nothing seems to work. :-/

    Cheers

    [0]: <a href=
    [1]: https://www.dropbox.com/s/95bzwvquh2syw
    [2]: https://www.dropbox.com/s/86dnljr7n9ywb

  • @“dragonmagick”:1tj28jnu said:

    After reinstalling the x86-video-ati and installimg xorg-xinit package for the startx command, I’m getting a black or pixelated screen after startx.[/quote:1tj28jnu]

    With the move to systemd, xinit and startx are no longer used.

    @“dragonmagick”:1tj28jnu said:

    I keep researching the issue and keep reading wiki pages plus other arch forums and trying out solutions. This is becoming a little frustrating at the moment since nothing seems to work. :-/[/quote:1tj28jnu]

    Don’t worry, we will figure it out
    gnome-session[244]: (gnome-shell:295): Gvc-WARNING **: Failed to connect context: OK
    systemd[401]: Failed to open private bus connection: Failed to connect to socket /run/user/1000/dbus/user_bus_socket: No such file or directory
    gnome-session[244]: (process:266): Gtk-WARNING **: Locale not supported by C library.
    /lib/colord-plugins/libcd_plugin_sane.so not loaded: plugin refused to load[/code:1tj28jnu]

    Something is not right with your system locale. Check the contents of /etc/locale.conf, It should look something like this:

      
    > > You will have to adjust according to your actual locale. Proper formatting and capitalization does matter here. I'd advise setting the LANG variable from above on the line below your own LANG variable except call it LANGUAGE.LANG="you\_locale.UTF-8"  
    > > LANGUAGE="en\_US.UTF-8"
    

    This will use the en_US as a fallback if there is a problem with loading the default. If that does not enable gnome-shell to load, the next thing to look at is the colord issues. The easiest thing here is just a total reinstall og gnome and its components:

    sudo pacman -Sy  
    > > sudo pacman -Rdd gnome --nosave  
    > > sudo pacman -S gnome
    

    Hopefully you will have some good new to report

    Best Regards,

  • Hey,

    thanks again.

    I followed your guidance and looked into locale.conf plus did a reinstall of GNOME. In locale.conf there was de_DE.UTF-8 which is correct, but I added the fallback nonetheless. At the end of the file I saw a L_COLLATE=C (or similar, can’t access the conf file right now and forgot the exact string).

    I rechecked the logs and can’t find the colord/locale warnings anymore, so that fixed something. Sadly, the system still doesn’t boot into gdm, it keeps sitting at the screen, depending on what I put into the boot arguments, not getting any visible errors there.

    Once again, here are the log files for your perusal:

    [https://www.dropbox.com/s/tr7e2ktugysm9i6/journal_20131211-1009.log][0]">[https://www.dropbox.com/s/tr7e2ktugysm9][1] … 1-1009.log

    [https://www.dropbox.com/s/a5d6bmg4v68afvs/Xorg.0.20131211-1010.log][0]">[https://www.dropbox.com/s/a5d6bmg4v68af][2] … 1-1010.log

    (Files are still uploading while writing this, should be finished soon)

    By the way, since I’ve started this thread I have reinstalled antergos from USB (a few days ago), out of the live system.

    Any further ideas?

    Cheers

    [0]: <a href=
    [1]: https://www.dropbox.com/s/tr7e2ktugysm9
    [2]: https://www.dropbox.com/s/a5d6bmg4v68af

  • You mentioned GDM, but Antergos does not install or use GDM by default. Actually I dont see anything in the logs related to GDM nor LXDM which is weird. Ensure that LXDM is enabled with “sudo systemctl enable lxdm” If it gives no output then it was already enabled. Any output will either be an obvious error or the steps systemd took to enable it. LXDM keeps its log at /var/log/lxdm.log so check there for any errors. I am kind of at a loss on this one

    If I find out anything more that could be useful I will update.

    Best Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/AM

  • I mentioned gdm, because it says “Starting GNOME Display Manager…” on screen when booting without “quiet” Anyway, lxdm wasn’t installed, so I corrected that. Enabling it gives the following error message: “Failed to issue method call: File exists”. There is no lxdm.log.

    Alright, trying Catalyst.

    Thanks for your prolonged attention to my issue, it’s appreciated!

    Cheers.

  • [b:3k6o6jf7]OKAYYYY[/b:3k6o6jf7],

    I am writing this from within Antergos!

    I quickly installed the Catalyst driver and, after a short, fearful moment, was greeted by the login. Login went through successfully, nice.

    Thanks for your help, Dustin!

  • You are welcome

    Cheers!

Posts 12Views 4779
Log in to reply