• How do I disable spellcheck globally?


    I write in several languages, and I use various technical terms and shortenings in all of them. I’m also a total grammar nazi, so I don’t need a spellchecker. As a result I disable it everywhere, and indeed I have done so in Chrome and Firefox, but I keep getting red underlines in all text forms.

    I can’t find a way to stop it. I’ve searched the options menu for what I assumed was a system-wide spell checker, but I haven’t been able to find a relevant option, not even by entering “spell” in the search fields. In desperation I even uninstalled aspell, hunspell, gtkspell and a couple other related packages from my system, and even that did nothing.

    Ideally I’d want the spellchecker the hell off my system, but I’ll settle for just stopping it if necessary - but how do I do that?

    Here’s a neat example, taken while writing this very post: http://i.imgur.com/fCyxrcD.png
    And before you ask - yes, I’m absolutely positive I’ve disabled Chrome’s own spell checker.

    I’ll add that it doesn’t seem to be running on non-web applications; for instance, gedit and libreoffice are unaffected. Firefox and Opera are, though, and again I’m absolutely sure their own spell checkers are disabled.

  • @drawyoursmile

    First, this is not an OS specific issue.
    It is a browser related issue.
    I understand that you initially thought it was a system - wide problem. But it is not.
    It is an app/soft specific issue.

    Because I am a nice guy on these forums and I like to help others out, I have Googled the issue for you.

    Have you done instead?

    Firefox> about:config
    services.sync.prefs.sync.spellchecker.dictionary ----------false
    services.sync.prefs.sync.layout.spellcheckDefault ---------false
    .

    or
    /home/drawyoursmile/.mozilla/firefox/drawsyousmile.default/pref.js
    add
    user_pref(“layout.spellcheckDefault“, 0); = Spell Check disabled

    For Chrome, sorry but as I am not using that browser, I do not know where you would look. What about a similar “about:config” for that browser. Is there something there, perhaps?

    If this has helped you, don’t forget to mark your thread as SOLVED

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Thanks. I Googled, but obviously not with the proper search terms, because I never got to that. I’ve done it and it seems to have mostly solved the problem in Firefox; I still get the occasional red line in Google, but text forms don’t seem to do it anymore. I wonder why the proper option had no effect, but this did.

    What did you search for to get there? I still have to fix the problem in Chrome.

  • Sure. No problem at all. :)
    I think one of the reasons that going through about:config is because via that route the settings are a bit more in depth whereas the settings via the regular Settings are just superficial. I don’t know. Am only taking a guess at it. But considering the effects it had, it would make sense that, that would be the conclusion.

    Happy to have helped.

    It’s incredible how frustrating small issues are yet it’s also quite important to resolve them as it makes our technological life a bit easier.
    As for the search terms, I just made a simple Google inquiry " remove spellchecker firefox"

    Got a link for you here for Chrome:
    http://ccm.net/faq/36877-google-chrome-how-to-disable-the-spell-checker

    Method 2 might be the one your after perhaps.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 4Views 579
Log in to reply