• No XFCE after installation


    Hello, i’m from Poland, so sorry for any mistakes.
    First i want to tell that i’m new with Antergos, both forums and system.
    I’t really great work you done with it, but…
    There is a small problem with the 2013.11.17 installation.
    I installed XFCE on a 32bit version on my netbook, and 64bit on my desktop, both installed “fine”, but after boot to the new system, the login screen shows there is no desktops installed.

    IJust in case the solution:
    switch to tty2 [ctrl+alt+F2]
    login to system
    sudo pacman -S xfce4
    reboot and login to your new system
    Enjoy.
    I’ts really nice distro and i really hope you will survive on the tuff linux market

  • Hello, i’m from Poland, so sorry for any mistakes.
    First i want to tell that i’m new with Antergos, both forums and system.
    I’t really great work you done with it, but…
    There is a small problem with the 2013.11.17 installation.
    I installed XFCE on a 32bit version on my netbook, and 64bit on my desktop, both installed “fine”, but after boot to the new system, the login screen shows there is no desktops installed.

    IJust in case the solution:
    switch to tty2 [ctrl+alt+F2]
    login to system
    sudo pacman -S xfce4
    reboot and login to your new system
    Enjoy.
    I’ts really nice distro and i really hope you will survive on the tuff linux market

  • Thanks for posting this information. We will be updating the iso ASAP as this issue has already been corrected in our master development branch,

  • Looks like the ISOs listed on the site still have this problem. When I rebooted after the install it wouldn’t take my password, I felt confident I entered it in correctly. I finally did a ctrl-alt-f2 and logged in to the console. It took my username and password. I then realized that xfce wasn’t installed even though I had chosen it during the installation.

    sudo pacman -S xfce4
    

    The above command got me back in business.

  • @“dowlf”:102zjma3 said:

    Looks like the ISOs listed on the site still have this problem. When I rebooted after the install it wouldn’t take my password, I felt confident I entered it in correctly. I finally did a ctrl-alt-f2 and logged in to the console. It took my username and password. I then realized that xfce wasn’t installed even though I had chosen it during the installation.

    sudo pacman -S xfce4
    

    The above command got me back in business.[/quote:102zjma3]

    We must have a regression on this bug.

    Cheers!

  • @“dowlf”:2ipj25dl said:

    Looks like the ISOs listed on the site still have this problem. When I rebooted after the install it wouldn’t take my password, I felt confident I entered it in correctly. I finally did a ctrl-alt-f2 and logged in to the console. It took my username and password. I then realized that xfce wasn’t installed even though I had chosen it during the installation.

    sudo pacman -S xfce4
    

    The above command got me back in business.[/quote:2ipj25dl]

    When i selected to install xfce it installed xfce, just not all of it needed to boot, i did’t pay attention to what exactly that was though.

    gmail: [email protected]
    irc: [email protected]

  • I’m having this same problem, although the method above hasn’t fixed it. From command line, Pacman appeared to download all the necessary xfce file, but I am still not able to log in, even after a restart. Help?

  • Did you use the official release ISO (11-17-2013) or testing? If you used the former, then you should have LXDM installed which give you a Blue login screen. Are you able to select Xfce from the session list? If not you can set the session in the lxdm.conf file. See here for more details: [https://wiki.archlinux.org/index.php/LXDM][0]">[https://wiki.archlinux.org/index.php/LXDM][1] Let me know if you still need help.

    Cheers!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/LXDM

  • @“lots.0.logs”:2wopku9y said:

    Did you use the official release ISO (11-17-2013) or testing? If you used the former, then you should have LXDM installed which give you a Blue login screen. Are you able to select Xfce from the session list? If not you can set the session in the lxdm.conf file. See here for more details: [https://wiki.archlinux.org/index.php/LXDM][0]">[https://wiki.archlinux.org/index.php/LXDM][1] Let me know if you still need help.

    Cheers![/quote:2wopku9y]

    I used the official ISO and it loads to the Blue login screen just fine. I am able to Xfce in the session list but when I select it and enter my password it goes straight back to the login screen.

    Out of curiosity and frustration I tried installing openbox from the console. That seemed to work and I can load that from the login screen, however I don’t seem to be able to launch any other programs :[

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/LXDM

  • another update: lxde works from the login screen and I think I may have narrowed down the problems a little bit. When I try to (re)install xfce4 there are 18 components to download. When I try them individually, the forst 12 work fine. The 13-18th however (xfce4-settings, xfce-terminal, xconf, xfdesktop, xfwm4, xfwm4-themes) come back with errors like this :

    error: failed to commit transaction (conflicting files)  
    ...  
    lots of file names followed by ... exists in filesystem  
    ...  
    Errors occurred, no packages were upgraded  
    
    
  • This probably happened because the meta/group xfce4 package – which tells which packages needs to be installed to fulfill the requirements of the group; in this case xfce4 – is different than the current meta/group xfce package. In other words, some of the names have probably changed.

    The easiest fix is to uninstall xfce4 with:

    pacman -Rcc xfce4
    

    This will uninstall all the old pieces and the files.

    Then turn around and immediately install the new xfce4 with:

    pacman -S xfce4
    

    If you still see a problem, you can run the same thing, but with --force on the end, like:

    pacman -S xfce4 --force
    

    Let Dustin or Gustau know if you still have a problem!

    Best…

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • This is still an issue for me, i downloaded the 64bit torrent version available on the download page and installed it into a virtual machine.

    All installed fine, i chose ‘Cinnamon’ as my desktop, upon rebooting all i got was a command line login.

  • @“MaNNa”:1qrco6qr said:

    This probably happened because the meta/group xfce4 package – which tells which packages needs to be installed to fulfill the requirements of the group; in this case xfce4 – is different than the current meta/group xfce package. In other words, some of the names have probably changed.

    The easiest fix is to uninstall xfce4 with:

    pacman -Rcc xfce4
    

    This will uninstall all the old pieces and the files.

    Then turn around and immediately install the new xfce4 with:

    pacman -S xfce4
    

    If you still see a problem, you can run the same thing, but with --force on the end, like:

    pacman -S xfce4 --force
    

    Let Dustin or Gustau know if you still have a problem!

    Best…[/quote:1qrco6qr]

    Thank you! This fixed the problem. I was having a similar problem getting Terminator to work and this fixed it as well.

    Is there a good way to figure out what other programs on my computer will also have outdated meta/group data?

  • Thank you! This fixed the problem.

    Praise God! Glad to hear this.

    Is there a good way to figure out what other programs on my computer will also have outdated meta/group data?

    I would use PacmanXG and look at the Groups section under Installed. Click on any Group there that you want to test and re-install to see if you get an error. When the Install dialog pops up, click on Install Options and select the option --needed, and that will tell pacman to re-install/install only the packages in the group that are not already installed.

    If you then see an error, you can follow the steps as you did before to fix it.

    With love…

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

Posts 14Views 1529
Log in to reply