• Live CD cannot boot on UEFI computer


    I made a bootable Antergos USB but when i try to boot it, after selecting the first option of the bootable menu, i get a black screen.

    I’ve search around the web and i could not find a solution for this problem. Which UEFI bootloader are Antergos using for Live CD?

    I had no problem with Ubuntu.

  • @Ilumex03

    1. What do you mean by which UEFI bootloader. UEFI is not a bootloader, it is an interface for replacing BIOS. Antergos, like many Linux OS use Grub. Antergos, uses Grub 2, if that helps a bit.

    2. Did you do an MD5sum check on the ISO? Many boot/install problems are contributed to by neglecting this.

    3. Use the dd program for writing the ISO to your USB. Do not use Unetbootin, Rufus, or something else. Use the dd with the arguments bs=2048 conv=noerror,sync at the end of the dd command.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I know what is UEFI but i should add “for”. Anyway i tried your suggestion and black screen again. However, when i boot Ubuntu’s live ISO into EFI/UEFI mode, grub2 is showed but if I do the same steps with Antergos, i get a gummyboot/systemd-boot bootloader which prevents me to boot into a live session of Antergos. That is what I wanted to explain.

    The Antergos solution for EFI/UEFI PC is not working for me. Another rolling release distro called KaOS uses the same boot system for EFI/UEFI PCs and it works.

    Thanks for replying.

  • Ok. I see what you mean now. You just had me wondering a bit there when you mentioned a UEFI bootloader. Regardless, confusion cleared up.
    You mentioned that Ubuntu and Kaos can both boot via USB just fine but Antergos cannot because of some interference from a gummyboot bootloader.

    1. I am going to assume that you went into your UEFI/BIOS and disabed the secureboot and now you are in legacy mode to boot and install onto. In other words, you need to try to boot into BIOS mode. Am saying this because not all distros, can/will work nicely with UEFI mode. Mine doesn’t and I have it in BIOS mode.
    2. Will also assume your USB is FAT32
    3. Will also assume that SATA mode turned to IDE
    4. Will assume that you took care of fastboot.
    5. Will also assume that (if you have the following, that is: CSM and PXE are both turned on )
    6. Will also assume that you set the USB stick to be first in boot order.
      The “Boot Device Priority” screen might only list a “Removable Device,” but some other menu on the BIOS’s Boot menu, like “Hard Disk Drives,” lists your HDD and an option for “USB.” So make the USB the primary HDD, go back to the Boot Device Priority menu, and ensure the USB is listed as an option.
    1. Will also assume that you have the correct bit - architecture for your computer. That is, either 64 or 32 bit.

    Some things to know about your computer.

    1. What type is it?
      You have not mentioned. Is it Asus, Dell, HP, made by some guy called “Mike the Mechanic” what…?

    Also, I will tell you right now that graphics is NOT the issue. Personally, I don’t care what you read on the Internet, but graphics is NOT the issue. It does not matter if you have Intel, nVidia, or some graphics card made by a talking cow. You should refute or disregard what somebody on the Internet tells you that it’s your graphics card.
    I just want to point that out.

    1. Are you seeing something like "Loading Initial Ramdisk..."
    2. I am also going to assume that you deleted & recreated the partition table on your USB rather than just writing it too USB when it had one from a former write. You need create a partition table onto that USB with either Gparted or some other program that can do that. It should reset things and allow you to reformat

    If it was not successful doing it with the dd command because you still wound up having the same issue, ok. Fine. No problem. Maybe it was not the result of doing it with dd but I prefer dd because some of the apps out there don’t do as good as a job as the built-in dd command that comes with ALL linux distros.

    Can you confirm ALL points from the above first.
    Will need to look at the obvious first before other workarounds and solutions are sought after.
    So please confirm ALL points/questions.

    I am not a guru at these things but I will help you as far as I am able to.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • This problem is more complex that I thought as i can see.

    @Modisc said:

    1. I am going to assume that you went into your UEFI/BIOS and disabed the secureboot and now you are in legacy mode to boot and install onto. In other words, you need to try to boot into BIOS mode. Am saying this because not all distros, can/will work nicely with UEFI mode. Mine doesn’t and I have it in BIOS mode.
    2. Will also assume your USB is FAT32
    3. Will also assume that SATA mode turned to IDE
    4. Will assume that you took care of fastboot.
    5. Will also assume that (if you have the following, that is: CSM and PXE are both turned on )
    6. Will also assume that you set the USB stick to be first in boot order.
      The “Boot Device Priority” screen might only list a “Removable Device,” but some other menu on the BIOS’s Boot menu, like “Hard Disk Drives,” lists your HDD and an option for “USB.” So make the USB the primary HDD, go back to the Boot Device Priority menu, and ensure the USB is listed as an option.
    1. Will also assume that you have the correct bit - architecture for your computer. That is, either 64 or 32 bit.

    Some things to know about your computer.

    1. What type is it?
      You have not mentioned. Is it Asus, Dell, HP, made by some guy called “Mike the Mechanic” what…?

    Also, I will tell you right now that graphics is NOT the issue. Personally, I don’t care what you read on the Internet, but graphics is NOT the issue. It does not matter if you have Intel, nVidia, or some graphics card made by a talking cow. You should refute or disregard what somebody on the Internet tells you that it’s your graphics card.
    I just want to point that out.

    1. Are you seeing something like "Loading Initial Ramdisk..."
    2. I am also going to assume that you deleted & recreated the partition table on your USB rather than just writing it too USB when it had one from a former write. You need create a partition table onto that USB with either Gparted or some other program that can do that. It should reset things and allow you to reformat

    My PC is unbranded, I mean, made by parts and has 3 modes for UEFI which are Windows 8, Windows 8 WHQL and Other OS. On each of them I can configure and set some options like the boot mode, LAN PXE and storage boot. But only if I select whatever Windows 8 option, I could configure CSM support.
    On the other hand, ´secure boot´ configuration is only shown if I select one of the ´Windows 8´ options.

    Currently my PC is set to Other OS with UEFI Only on boot mode and storage boot.
    SATA mode is set to AHCI and Fastboot is disable because is crappy for me.

    Booting Antergos live CD ISO into UEFI mode, it shows me 5 entries which are Antergos x86_64 UEFI CD, UEFI Shell x86_64 v1, UEFI Shell x86_64 v2, EFI Default Loader and Reboot Into Firmware Interface.

    If I select the first option, I only see a black screen. No text or whatever.
    If I select the second option, a UEFI Shell will be showed
    If I select the third option, an error is shown Failed to execute UEFI Shell x86_64 v2 (\EFI\shellx86_64 v2.efi): Not Found and then a blue screen appears with a similar error and a “OK” button.
    Fourth fails
    Fifth entry brings me to the UEFI configuration menu.

    If it was not successful doing it with the dd command because you still wound up having the same issue, ok. Fine. No problem. Maybe it was >not the result of doing it with dd but I prefer dd because some of the apps out there don’t do as good as a job as the built-in dd command >that comes with ALL linux distros.

    You’re right, I always make bootable USBs with dd because other tools like Unetbooting could not work and are not as powerful as dd.

    I am not a guru at these things but I will help you as far as I am able to.

    Don’t worry, I really appreciate your help

    UPDATE:
    I could test Arch Linux ISO and it boots perfectly, it seems to be an Antergos specific problem

    Thanks. Bye.

  • I could boot uefi Antergos disabling secureboot and write the usb with RUFUS, the other way i have ever problems.

  • @llumex03
    I see what you are faced with now. This is a bit more complex than I initially imagined myself as well.

    I am going to mention this straight out at the onset of this and I may have to tell you that perhaps Antergos is just not set up for how your custom system is. Though, in having said that, it should be because as technology changes, so do (and should Operating Systems).
    So maybe the Antergos devs are just not there yet at this point in time.

    Please read this,
    I went to the Arch Wiki (UEFI wiki page) and read this:

    On some UEFI systems the only possible way to launch UEFI application on boot (if it does not have custom entry in UEFI boot menu) is to put it in this fixed location: /EFI/BOOT/BOOTX64.EFI (for 64-bit x86 system)
    

    In having just posted/quoted that, what is supposed to happen is that your firmware is supposed to read the boot manager’s data and then determine which UEFI application is to be launched (you have 3 you mention). Apparently, that is not happening.

    And because you cannot even boot live with Antergos, most obviously you cannot even do a simple task such as
    cp /path/toEFI/grubx64.efi /path/to/efi/shellx64.efi to allow yourself to get started.
    Hmmph!

    Finally, you seem to have all the other ingredients correct for initially wanting to use Antergos prior to starting it as a Live CD.

    I have to tell you that at this point, I would be stumped. I do not know where to go at this point to further help you. A process like this might be quite exhausting. Too time consuming and to be honest, I think it’s also important to ask yourself if the exhaustion and strength of effort are necessary just to get an operating system going.

    This is beyond my knowledge base and I would rather that someone with more experience follow through with this, then.

    If you prefer the real Arch, go ahead. Best of efforts to you.

    I should also tell you that there are other rolling releases out there and they DO NOT include Manjaro, like what some people might like to use.

    I also use Chakra – Arch based. Has own repos that, that system uses.
    KDE is default. Stable too. chakra linux

    Am only mentioning this if you are looking for something other than Manjaro and true Arch.
    Bridge LInux too. bridge linux

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I would like @developers take a look into this post because i don’t know why Arch Linux ISO boots up and Antergos being an Arch-based, not.

    @Modisc

    I have to tell you that at this point, I would be stumped. I do not know where to go at this point to further help you. A process like this might be quite exhausting. Too time consuming and to be honest, I think it’s also important to ask yourself if the exhaustion and strength of effort are necessary just to get an operating system going.

    I’m sure at 100% that this problem is affecting to more people and i would like to help the community. If anyone try to solve it, then it won’t be never fixed.

    This is beyond my knowledge base and I would rather that someone with more experience follow through with this, then.

    Developers, developers, developers, developers… :laughing:

    If you prefer the real Arch, go ahead. Best of efforts to you.

    I only did a test to check that this problem is not happening on the main distro. I’m not going to move to Arch Linux because I don’t want to spend my time installing it.

    Thanks. Bye

  • Hi,
    apparently your BIOS is set to UEFI only.
    Have you tried to set it to UEFI & Legacy or Legacy only or anything available allowing not to be UEFI only ?
    Then, after doing that, do you have an option to set CSM to On ?

    Good luck

  • HI!!! I have the same problem. I created an usb bootable with dd and I only can see the first selection menu (Antergos UEFI…), then, only a black screen and a (too fast dissapears) message, imopssible to read, and then, back to bios boot screen.
    I tried the ISO on Virtualbox on EFI mode, and no problems.
    What happen??
    Thanks!!

  • @Jordi_S.
    I downloaded a minimal iso and I burned to CD and not booted, the problem is the same.

  • Hi Jordi_S

    what are your BIOS options regarding Fast boot, Secure boot, Legacy CSM… ? Look at the posts before yours.

  • Boot opions are deactivated and I can’t see a CSM option…

    Seems a problem with radeon, I tried with Architect and booting with nomodeset, an error appears:

    NO UMS SUPPORT in radeon module

    Of course, the gui installation don’t appears in this mode.

  • What are the brand and model of your laptop ?

  • Is an AMD A6-5400K, with integrated Radeon HD 7540D, motherboard is MSI A68HM-P33 V2, and 8gb RAM.

  • @Jordi_S. Hi

    I just looked online at your motherboard manual. The BIOS menu description is very light and I didn’t find what I expected.
    Be sure to deactivate Fast Boot in your BIOS and try to find the option not to boot in UEFI mode only but also in legacy mode.
    It might improve. If not, sorry, I cannot help you more here.

    Good luck

  • I have the same error, asus gl552 laptop with nvidia gtx960m…
    Only can see a black screen.

  • Oh, I missed to reply this…I tried arch and other based distros and seems the problem is the same. I only say this for reference, i like more antergos or arch, but manjaro boots without problem, I will switch from lubuntu to Manjaro. Thank you for all!

uefi35 efi6 antergos-iso4 bios15 Posts 19Views 8572
Log in to reply