• Antergos only working with nolapic kernel option


    Hello,
    I recently tried installing antergos on my laptop.
    First of all, the system would not boot. After some googling I learned about several kernel options that can be specified on boot.
    The system is booting with the kernel options “nolapic, i915.preliminary_hw_support=1, i915.modeset=1” and could successfully install the system. However, most likely due to the nolapic kernel option, Antergos only utilizes one CPU core. If I omit “nolapic”, there is a black screen immediately after booting. If I specify “debug”, the kernel will die after the lines “intel p-state driver initializing” and “intel_pstate: HWP enabled”. Otherwise, there is no kernel output.
    Any ideas on how to replace the nolapic option?

    My system is an Intel i7 6500U with the integrated Intel HD 520. There is no other graphics card.

  • Hello again,

    so, I found a solution, but I am not sure in how far it influences my system. I can omit “nolapic” and add intel_pstate=disable. It seems that linux with Kernel later than 3.9 have problems with that driver. I think it is for powermanagement of the CPU but I am not sure. So this fixes the problem with only one CPU activated.

    If there are any issues caused by this, it would be great if you tell me.

    Max

  • @swarmchaos said:
    It seems that linux with Kernel later than 3.9 have problems with that driver.

    Even if using the LTS kernel?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Didn’t try that because it works with deactivating pstate. It is mentioned in Arch-Wiki, so I think they know about it and i hope they work on it.

intel25 kernel76 boot162 Posts 4Views 861
Log in to reply