• /etc/default/grub


    Hello everybody.

    Can someone please give me an /etc/default/grub file that is as close as possible to the default one (preferably unmodified) generated by the installer. I did some terrible terrible things to mine:(

  • Why don’t you re install it? it’s better option.

  • I don’t want to bother…the sys works…just some config options (mainly resolution) are screwed.

  • Hope this helps. This is my config from my AMD xfce4 build (only thing I changed was the timeout from 5 to 1)

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=1
    GRUB_DISTRIBUTOR=“Antergos”

    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=253f7c9b-cdba-4456-a5b3-913e2e3b68f9 quiet "

    GRUB_CMDLINE_LINUX=""

    #Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    #Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    #Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console

    #Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console

    #The resolution used on graphical terminal
    #note that you can use only modes which your graphic card supports via VBE
    #you can see them in real GRUB with the command `vbeinfo’
    GRUB_GFXMODE=auto

    #Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep

    #Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    #format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”
    #GRUB_DISABLE_LINUX_UUID=true

    #Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true

    #Uncomment and set to the desired menu colors. Used by normal and wallpaper
    #modes only. Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    #Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"

    #Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE=“480 440 1”

    #GRUB_SAVEDEFAULT=“true”

  • @alaguna said:

    Why don’t you re install it? it’s better option.

    I agree that it probably is better to re-install Antergos. If you have a separate / and **/home **partition it should not be a problem. Otherwise try to back-up your important files otherwise you will lose everything during the install.

    An other option. Have you tried to update Grub?
    Use:
    grub-mkconfig -o /boot/grub/grub.cfg

    in terminal.

    Never to old to learn.

  • I mean reinstall grub 😄

  • @alaguna 👍

    Never to old to learn.

  • I made it work. Thanks to everyone for help!

Posts 8Views 1889
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.