• What's happening with my system?


    I’ve recently tried to install the Nvidia drivers, I had multiple times where the xorg.conf was causing problems and failing to boot for reasons such as not being able to find a screen. When this happened I just renamed the xorg.conf to something like xorg.conf.bak, or make changes with sudo nano, was usually easier to play using gedit for copy/paste and browser reference. sudo nvidia-xconfig was used both in Gnome session terminal and in tty1 when X wouldn’t boot, it just failed to make a proper xorg.conf on it’s own. I’ve had some success at getting it to boot but performance did not seem correct compared to how it was with Ubuntu.

    I’ve since uninstalled the nvidia and nvidia-utils packages via pacman in terminal and reinstalled nouveau, removed blacklist-nouveau.conf, commented out a line to run a shell script for lightdm listed on the Arch Wiki. So everythings technically good now, I’ll try again with proprietary drivers later, or not as I’m considering VGA passthrough to a Windows VM(and perhaps also Linux VMs rather than traditional installs).

    During these events, I had a nice 1920x1080 resolution desktop but windows were opening in a small top left section, perhaps they thought the resolution was cramped to 640x480 or something? The majority of drop downs or right click menu’s even file menu’s were barely visible at the top left, I couldn’t actually select anything. This made certain actions difficult since I didn’t know the shortcuts. Right click on Gnome Dash or the top right panel menu for shutting down were still working correctly.

    Often I’d log in and all Gnome extensions were disabled, sometimes my time was reset to Jan 1 2009(Laptop was available to retailers in Q12014). The top right menu had settings and shutdown buttons but the lock/suspend had disappeared(and these still have not returned), I’m guessing like Gnome extensions there is a setting for these to be enabled? Super+L still locks, shutting the laptops lid also suspends. I’m not sure why these bugs(?) have occurred from switching the drivers.

    I’d like the two buttons back if possible, and any information to understand what exactly caused these issues.

  • Have you a hybrid gpu or single cpu? I mean intel/nvidia or nvidia only? if a notebook?

  • @alaguna Laptop with 860M, I have no branding for Optimus but someone had linked in the past that it supports Optimus, I have intel gpu as well. I’m aware of Nvidia Prime and Bumblebee, I had tried to get this working under Ubuntu previously and had similar problems getting it to work(at one point I lost the Unity environment, or it was not properly loaded, dash and panel were missing for example).

    I’m going to look at doing vga passthrough to a VM now. My hardware supports it, the intel gpu will be used for host Antergos and the nvidia gpu will be used for VMs(Windows mostly but perhaps Linux too for easy switching without having to reconfigure and reboot to return nvidia gpu to host).

    My main concern is with why DE features were acting up, like my Gnome Extensions all being disabled. Several reboots when I was able to log in they kept being all disabled, it’s fixed now though since reverting to Nouveau and removing the Nvidia drivers, my enabled extensions stay enabled on reboots. The top right drop down menu though still only has settings and shutdown buttons(all the rest above that seems fine btw), I’m not sure what I need to do to restore lock/suspend buttons.

  • Did you use the nvidia-settings having optimus bumblebee system? This is a big problem, see Antergos wiki about bumble bee.

drivers29 gnome203 bug11 Posts 4Views 893
Log in to reply