• Mount additional SSD partition?


    I have a data partition I created prior to Antergos installation with gparted. I can see it in the file manager under Other Locations with the label I gave it data and mount point /dev/sda4. I’d like to have it show on the sidebar like when external drives are plugged in if possible.

    My issues are that it’s ownership is root, how can I gain write access? I’ve looked at the partition vs my Antergos /home partition and as this is an SSD I think I should be adding some extra mount options like noatime discard? I’ve not edited fstab before, does this Gnome app Disks provide a UI that modifies that? It has the partition set to Auto Mount.

  • @pola Which filesystem is using?

  • @karasu EXT4 for everything. Bar the ESP boot partition which is FAT32.

  • Hi,

    Then you must change your folder and files permissions if you want to be able to modify them with your user.

    Instead of giving you a command, I’ll share with you a wiki page:

    https://wiki.archlinux.org/index.php/File_permissions_and_attributes

    But if you have any doubts, feel free to ask here again, of course!

    Cheers!

  • @karasu I’ve still not been able to get any feedback on the mount options for the partition being on a SSD here or on my reddit thread. Someone suggested mounting with udisks2 which I’ve noticed installed, I haven’t tried this, not quite sure what the benefit is over editing fstab?

    I’ve verified that the Gnome Disks app does modify the fstab file adding/modifying entries there. I’m not sure what this lost+found folder is which has 0 items, I understand the one in / but there doesn’t appear to be one on my other partition /home. In the file manager it had a red X icon over it originally with ? items and noted as unreadable. I formatted the partition with the Gnome Disks app, the folder is still there and unreadable but states 0 items. Ownership of this folder alone is root the rest is Me. I’m told 1.8% of the partition is used but there is no data there?

    Prior to the format I had the fstab entry and the partition mounted, no write permissions. fstab entry hasn’t changed besides the new UUID:
    UUID=b0970df4-db1b-4934-b19d-cf470a3750f4 /mnt/data ext4 defaults,rw,noatime,discard 0 0 , I’ve copy/pasted the mount options from /home .

    Should I run chown root /mnt/data to fix ownership? I’d like to be able to read/write/execute anything on the data partition regardless of user account or current distro. chmod o=rwx /mnt/data seems right? I don’t have any files on the partition atm so no need to use the find command. What happens when I copy files over to it or create them as my user without sudo? I’ll be labelled as the owner right? But will the permissions not be rwx for everyone unless I chmod them afterwards? Is setting up ACLs or something else better in this case?

partition35 ssd27 mount23 Posts 5Views 1345
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.