• Touchpad toggle via function key cannot disable


    My laptops touchpad can be enabled/disabled by a function key. When used I get the correct visual indication of it’s state, and I can see in the mouse settings that it’s being toggled on/off. It fails to actually disable the touchpad when off though, this only works by clicking the toggle switch on the settings ui from on to off. The function key is still able to enable the touchpad again. Is this an Antergos integration bug or should I report it somewhere else?

  • correct me if I am wrong, but you want to disable your touchpad?
    synclient -l
    what does it say on “Touchpad”?
    As reference material, man synaptics and the Arch Wiki have some info.
    The Wiki has a page for touchpad in it.
    You could also try to control it with syndaemon but I don’t think that it would help you much.
    If you only want to disable it part-time, you could try syndaemon -i <idle-time> after enabling the daemon first.
    But again, I suspect that is not what your looking for.
    Check man syndaemon

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc It says TouchpadOff = 1 I’ve got it disabled now via Gnome Settings. My issue was with function key to enable/disable, it only enables, does not disable. It’s not a major issue since I’ll switch infrequently, just convenient for when moving around without the external mouse touchpad is handy, otherwise at a desk plugged in I prefer to have it disabled.

    Ubuntu handled it fine as well as a Fedora distro from memory, along with disabling/enabling when the external mouse availability changed. So this is an issue with Arch’s packages?

  • @pola
    So since your Touchpad = 1, you might already be aware that, that integer means
    Touchpad is switched off (physical clicks still work) I think that is only partially what you want. To my understanding, you want to disable the whole thing (touchpad) on an ad hoc basis. But the problem is that the touchpad does not actually remain disabled when attempted so using the selected "function"key.
    The Fn key?

    Question: What DE are you using? Am asking because the Arch Wiki has some information on the touchpads for some of the various DEs, such as Openbox, Gnome, etc…
    For example, if using Gnome, it does not provide a whole lot of information but…:

    Mouse and touchpad
    
    To help reduce touchpad interference you may wish to implement the settings below:
    
        Disable touchpad while typing
        Disable scrolling
        Disable tap-to-click
    

    I have had a look through gsettings and I do not find anything there relating to the Fn key (key bindings in particular, that is).

    To continue with your Fn key ( I believe that is what you might be referring to when you mention the ‘function’ key) not disabling the function you want disabled, that is kind of strange. It would logically seem that if a function could be enabled, it would conclude that, that same function could/should also be disabled and hence the availability of it. And effectively as well since you mention that the " function " key only enables but does not disable.

    You could try doing what the Wiki has available ( I am not 100 percent sure if you want to take this route but you can have a read of it. I know this issue is not a major concern for you but still, I’m just putting it out there for you in case).
    Xbindkeys

    From the Wiki

    Xbindkeys is a program that allows to bind commands to certain keys or key combinations on the keyboard
    

    There is a GUI program to use where you would need to install xbindkeys_config and then just run the program xbindkeys_config

    Am wondering if that would work for you in find a way to disable the touchpad how and when you want it to with the distinct possibility of ensuring that it remain disabled.

    Something else that comes to mind and that is perhaps that the disabling of the touchpad using the Fn key is disabled by default.
    I would not know where to start looking for that. It would/could be a config file somewhere. Sorry, not sure where though.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

touchpad28 laptop20 Posts 4Views 1223
Log in to reply