• Persistent problem with locale clock in gnome


    Hi guys, how are you?

    In this post, i will put here a persistent problem with my computer and antergos.
    I couldn’t put spanish language for live os and i have change the language once time this begin, i installed antergos and all is well, but when antergos begin clock has a gap, a -5 hours gap. I can solve it changing manually the hour and set correct hour in the bios, but when i begin antergos again, i found the gap again, i don’t know why :’(

    Can anyone help me? The solution wroks by two days. I haven’t this problem in windows.

    If you need a log, here are:

    date && sudo hwclock --debug && timedatectl status && ls -l /etc/localtime
    mar ene 12 21:35:30 COT 2016
    [sudo] password for salahaddin: 
    hwclock de util-linux 2.27.1
    Se utiliza la interfaz /dev al reloj.
    Último ajuste de desfase realizado 1452561401 segundos después de 1969
    Última calibración realizada 1452561401 segundos después de 1969
    El reloj de hardware tiene la hora UTC
    Se presupone que el reloj de hardware tiene la hora UTC.
    Esperando señal de reloj...
    ...recibida señal de reloj
    Hora leída del reloj de hardware: 2016/01/13 02:35:34
    Hora del reloj de hardware: 2016/01/13 02:35:34 = 1452652534 segundos desde 1969
    El tiempo transcurrido desde el último ajuste es de 91133 segundos
    El desfase del reloj de hardware calculado es de 0,000000 segundos
    mar 12 ene 2016 21:35:33 COT  0,498374 segundos
          Local time: mar 2016-01-12 21:35:34 COT
      Universal time: mié 2016-01-13 02:35:34 UTC
            RTC time: mié 2016-01-13 02:35:34
           Time zone: America/Bogota (COT, -0500)
     Network time on: no
    NTP synchronized: no
     RTC in local TZ: no
    lrwxrwxrwx 1 root root 34 ene 10 08:23 /etc/localtime -> /usr/share/zoneinfo/America/Bogota
    

    Sorry but, i don’t know how put code type.

    Thank you very much for your help.

  • Are you using Windows on the same machine?

    Try this:

    sudo timedatectl set-local-rtc 1

  • @karasu Yes, i’m using windows, i had read that they change bios clock.

  • If you’re using Windows 7 and upwards, everything should be fine.

    Have you tested the command I put in my last post? Did it have any effect?

  • @karasu
    I have this:

    [[email protected] ~]$ sudo timedatectl set-local-rtc 1
    [sudo] password for salahaddin: 
    [[email protected] ~]$ date && sudo hwclock --debug && timedatectl status && ls -l /etc/localtime
    mié ene 13 08:05:59 COT 2016
    hwclock de util-linux 2.27.1
    Se utiliza la interfaz /dev al reloj.
    Último ajuste de desfase realizado 1452561401 segundos después de 1969
    Última calibración realizada 1452561401 segundos después de 1969
    El reloj de hardware tiene la hora local
    Se presupone que el reloj de hardware tiene la hora local.
    Esperando señal de reloj...
    ...recibida señal de reloj
    Hora leída del reloj de hardware: 2016/01/13 08:06:00
    Hora del reloj de hardware: 2016/01/13 08:06:00 = 1452690360 segundos desde 1969
    El tiempo transcurrido desde el último ajuste es de 128959 segundos
    El desfase del reloj de hardware calculado es de 0,000000 segundos
    mié 13 ene 2016 08:05:59 COT  0,248222 segundos
          Local time: mié 2016-01-13 08:06:00 COT
      Universal time: mié 2016-01-13 13:06:00 UTC
            RTC time: mié 2016-01-13 08:06:00
           Time zone: America/Bogota (COT, -0500)
     Network time on: no
    NTP synchronized: no
     RTC in local TZ: yes
    
    Warning: The system is configured to read the RTC time in the local time zone.
             This mode can not be fully supported. It will create various problems
             with time zone changes and daylight saving time adjustments. The RTC
             time is never updated, it relies on external facilities to maintain it.
             If at all possible, use RTC in UTC by calling
             'timedatectl set-local-rtc 0'.
    lrwxrwxrwx 1 root root 34 ene 10 08:23 /etc/localtime -> /usr/share/zoneinfo/America/Bogota
    

    Didn’t solve anything.

    No solved yet, and i don’t want enable ntp, not in all place i’ll have wifi.

  • Unsolved yet!

  • Hi,

    Undo what I told you:
    sudo timedatectl set-local-rtc 0
    And then, activate NTP synchronisation:
    sudo timedatectl set-ntp true

  • @karasu Ok, but, if i haven’t internet for any reason, what could i do?

    I thin say that:
    This problem, again, was caused because i couldn’t select my user language using F2, because i have to use Rufus to create the live usb, because Image Writer and terminal command make a wrong image in live usb that didn’t leave me install Antergos.

    I think that you should make better cnchi and antergos installation.

  • I couldn’t select my user language using F2

    You should create your usb live with the dd command. Anyway, I doubt your problem has any relationship with it. I live in Europe and Cnchi installs fine here (with GMT+1).

  • @karasu Friend, with dd i had many problems for install, i couldn’t install Antergos using these command for write the image, nor ImageWriter, only with Rufus i could install it.
    I haven’t problem now because ntp. But, again, if for any reason i couldn’t connet to internet? What i could do ?

    Until yet i can’t put this thread as solved.

    What’s up guys?

bug11 locale6 clock8 Posts 10Views 1622
Log in to reply