• How to add LTS kernel to GRUB

    Hi Forum!

    I’ve installed the LTS kernel (linux-lts) and I am trying to add it to GRUB, but wasn’t successful so far. I’ve found an old thread about this subject ((https://forum.antergos.com/topic/1186/solved-lts-kernel) ) but it contains a link to the solution is no longer available.

    What I’ve tried so far:

    • installed linux-lts
    • removed executable flag from /etc/grub.d/10_antergos
    • added executable flag to /etc/grub.d/10_linux
    • re-created grub.cfg again with grub-mkconfig

    But the LTS kernel is not available in the grub menu after a reboot.
    I’ve also tried to add an entry to the 40_custom entry, but also failed.
    Could anybody shed some light on this? Thanks!


  • You need to update your grub using this…
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • As written I did update grub.cfg with grub-mkconfig but to no avail.

    It seems though that I’m not using GRUB at all but instead still relied on EFI and gummiboot from the old Arch installation.

  • @sargon Try you seeing in the option: More advance options for Antergos?

Posts 4Views 1214
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.