• Totem ("Videos") won't play video files. Gives error "Could not initialize supporting library".


    I’ve recently come across an issue with the Totem application (now “Videos” in GNOME) that it won’t play most of my videos, saying “Could not initialize supporting library”. I’m assuming this is because I don’t have the necessary codec packages to read it (assuming). Ubuntu has a single package called “Ubuntu-restricted-extras” that has all of the proprietary multimedia packages and codecs one would need to play audio and video files with proprietary codecs.

    Does Antergos/Arch have anything similar? I’d prefer not to search and experiment with finding the right, necessary packages for this.

    Thanks in advance!


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • @jesse.dubord i dont think arch as a package like that. what is the file type that you are trying to open? have you tried smplayer or vlc just to test out the video?

  • @jesse.dubord said:

    issue with the Totem application (now “Videos” in GNOME) that it won’t play most of my videos, saying “Could not initialize supporting library”.

    What format are the videos? We install all the available codecs by default so you should be able to play all the common video formats.

  • Try this from console or installed this AUR package from pamac:
    yaourt -S libde265.
    As i remember, one month ago, Totem (or any other GStreamer player) was unable to play some h265 encoded videos, despite of default installed x265 package.

    My advice - use VLC or MPV frontend (SMplayer, Gnome-mpv).

    a warm place with no memory

  • Thanks for the replies, all.

    @megaman , I’ve tried .avi and .mov and .mp4 (darn near any video file I have) using the h.264 codec, aac audio codec, mpeg 4 avc. VLC plays the videos just fine.

    @lots-0-logs , interesting about installing the codecs by default. Perhaps it’s an issue with Totem, but I can’t imaging what…?

    @roberto , thanks for the suggestion. I built and installed the package, but to no avail. :/ I’m currently using VLC, though I’d like to use Totem. VLC works, but I’d expect Totem to be in working order out of the box for all of the formats that lots.0.logs says are playable.


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Running totem from terminal produces this:

    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns -1
    libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/dri/nvidia_drv_video.so
    libva info: va_openDriver() returns -1
    libva info: VA-API version 0.38.1
    libva info: va_getDriverName() returns -1
    libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
    


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • I’ve updated the thread title to be more appropriate – in case future users come across this and find any solutions posted here helpful. :)


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Remove gstreamer-vaapi

    sudo pacman -R gstreamer-vaapi

    But, yes, vlc is much better (imho).

    EDIT: It’s a known bug. Removing vaapi will disable hardware acceleration for totem, though.

  • That solved it! Thanks @karasu!


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • SMPlayer with MPV is another excellent and better performing alternative to VLC.

  • @Arup-Roy-Chowdhury MPV is really coming on strong of late. i like it :+1:

  • @megaman indeed lots of development its the natural successor to mplayer and I find it running far better than vlc, I use SMPlayer as front end and vdpau and other work is handled quite well as is proper support for all formats.

  • Just remove (uninstall):

    gstreamer1.0-vaapi

    and optional:

    i965-va-driver

    Then delete the folder:

    rm -r ~/.cache/gstreamer-1.0

    Also if codecs are still missing, after reboot, install:

    ubuntu-restricted-extras

    or if in other distro change from:

    oxideqt-codecs

    to:

    oxideqt-codecs-extra

    commands to get more info:

    /usr/bin/gst-inspect-1.0
    /usr/bin/glxinfo
    /usr/bin/vainfo

  • @karasu Hello pal, thank you, I have just installed Antergos and was testing some tools e.g. screencast(Ctrl+Alt+Shift+R) or recording videos with “Cheese App”. But I was having problems for playback theirs with “Videos”(GNOME Videos).
    “Videos” was showing me the following message

    could not initialize supporting library

    This command solved my problem.

    sudo pacman -R gstreamer-vaapi
    
Posts 14Views 6667
Log in to reply